Bug 171501 - update-desktop-database, gtk-update-icon-cache, omit .la files
update-desktop-database, gtk-update-icon-cache, omit .la files
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libkipi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-21 17:19 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-21 18:41:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2005-10-21 17:19:36 EDT
Per
http://fedoraproject.org/wiki/ScriptletSnippets
since libkipi includes icons, it ought to include in %%post,%%postun:
touch --no-create %{_datadir}/icons/hicolor ||:
gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:

And, you can omit packaging those pesky libtool archives:
/usr/lib/lib*.la

p.s.  Were you intending on packaging digikamimageplugins and/or kipi-plugins? 
If not, I can submit them for review.
Comment 1 Rex Dieter 2005-10-21 17:54:55 EDT
Also, since digikam has MimeType= entries in it's .desktop files, you should
also add to %post,%postun:

update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
Comment 2 Aurelien Bompard 2005-10-21 18:41:49 EDT
Thanks Rex, changes commited and rebuild underway.
Feel free to package digikamimageplugins and kipi-plugins if you want to.
If you want to co-maintain libkipi with me in Extras, no problem. Just commit
your changes.

Concerning digikam, it is maintained by mgarski@post.pl according to owners.list.
Comment 3 Rex Dieter 2005-10-21 20:46:41 EDT
Any reason why FC-3 branch is still at 0.1.1?
Comment 4 Aurelien Bompard 2005-10-22 03:17:20 EDT
Yep, I don't have an FC-3 system to test it on. If you have one and it works
fine on it, please tell me and I'll update it.
Comment 5 Rex Dieter 2005-10-22 09:21:32 EDT
I can vouge for it, we've had libkipi-0.1.2 available for fc3 since it's release
(from kde-redhat).

Note You need to log in before you can comment on or make changes to this bug.