Bug 171508 - gtk-update-icon-cache
gtk-update-icon-cache
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: konversation (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-21 17:58 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-23 01:08:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2005-10-21 17:58:10 EDT
Per
http://fedoraproject.org/wiki/ScriptletSnippets
since this package includes icons, it ought to include in %%post,%%postun:
touch --no-create %{_datadir}/icons/hicolor ||:
touch --no-create %{_datadir}/icons/crystalsvg ||:
gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
gtk-update-icon-cache -q %{_datadir}/icons/crystalsvg 2> /dev/null ||:
Comment 1 Michael Schwendt 2005-10-22 03:48:30 EDT
Touching the icon theme top directory, well, acceptable.
But running gtk-update-icon-cache is polluting a KDE app package spec
with stuff that doesn't belong in there, IMO.
Comment 2 Rex Dieter 2005-10-22 09:17:43 EDT
> But running gtk-update-icon-cache is polluting a KDE app package spec
> with stuff that doesn't belong in there, IMO.

Agreed.  It can be omitted, but the touch, at least, is required by the icon spec.

One of these days, the gtk2/gtk-update-icon-cache maintainer will see the light
and make gtk-update-icon-cache a periodic cron-job as it should be (see bug #170335)
Comment 3 Dennis Gilmore 2005-10-22 15:37:23 EDT
i agree with Michael  on this.  definetly for KDE packages  there should be no  
need to add stuff that is gnome specific. something  like that that will touch  
so many packages should be automated because packages will slip through the  
cracks.  
 
Which icon spec are you talking about? 
Comment 5 Dennis Gilmore 2005-10-23 01:08:47 EDT
ok   
 
i am not going to add the gtk-update-icons part  but i have added the touch on 
the dir. 

Note You need to log in before you can comment on or make changes to this bug.