This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 171517 - NM won't switch to wired network
NM won't switch to wired network
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-21 19:30 EDT by Matthew Saltzman
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-22 23:32:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2005-10-21 19:30:57 EDT
Description of problem:
Once connected to a WAP, NM does not revert to wired when wire is plugged in.

Version-Release number of selected component (if applicable):
NetworkManager-0.5.1-1.FC4.1

How reproducible:
Always

Steps to Reproduce:
1. Start NM and connect to WAP
2. Plug in a wire.
3.
  
Actual results:
Nothing happens.

Expected results:
NM should switch to the wired connection.

Additional info:
Comment 1 Dan Williams 2005-10-22 22:36:07 EDT
quick check, at any point with 5 - 30 seconds after you've plugged the cable in,
what does /sys/class/net/<your network device>/carrier say?  If it says "0" the
it's a kernel problem since that means the kernel doesn't know its connected. 
If it says "1", then its a NetworkManager problem.
Comment 2 Matthew Saltzman 2005-10-22 23:32:50 EDT
Well the first time I looked, it said "invalid configuration" or something to
that effect.  I rebooted with the wire plugged in just to see what happened and
it worked.  /sys/class/net/<my wired device> switches between 0 and 1.

Now it works regardless of whether I boot with the wire in or not.

So it's working for now, and I can no longer reproduce the problem.  If things
change, I'll open a new bug.

Note You need to log in before you can comment on or make changes to this bug.