Bug 171531 - Yum updates of kernel change default kernel in grub.conf
Summary: Yum updates of kernel change default kernel in grub.conf
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-22 13:29 UTC by Steve Hill
Modified: 2014-01-21 22:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-26 16:07:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Hill 2005-10-22 13:29:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-UK; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
When doing "yum update", if the kernel is updated it is installed and the default=<foo> parameter in the grub.conf is updated to default=0 even if it was set to a non-zero value before the update.

Version-Release number of selected component (if applicable):
2.6.13-1.1532

How reproducible:
Always

Steps to Reproduce:
1. Set the default=<foo> parameter in grub.conf to a non-zero value
2. Do a yum update after a new kernel package has been released

Actual Results:  The default=<foo> parameter in the grub.conf is updated to default=0 even if it was set to a non-zero value before the update.

Expected Results:  The default=<foo> parameter should still point at the kernel it pointed at before the update if it was non-zero to start with.  (Maybe there should also be an option somewhere to stop it being reset if it is set to 0 too).

Additional info:

This is very bad - on some machines I _know_ I will have to do some manual stuff (recompiling external kernel modules, etc) after a new kernel has been installed before it can be brought into service.  The last thing I want is for the machine to be rebooted to the new kernel when I'm not in a position to do the manual stuff - it should reboot into the kernel I had manually told it to use instead of the latest.

The result is that after a reboot (maybe a power outage, etc) this may leave a machine either partially or completely useless until the administrator is able to fix the problem.

Comment 1 Seth Vidal 2005-10-25 12:46:16 UTC
reassigning to mkinitrd since that does the grub modifications.

Well, that or grubby.

Comment 2 Jeremy Katz 2005-10-26 16:07:07 UTC
If you don't want the kernel changed by default, set /etc/sysconfig/kernel
accordingly.


Note You need to log in before you can comment on or make changes to this bug.