Bug 171540 - System boot freezes at Remounting root filesystem in read-write mode: succeeded
System boot freezes at Remounting root filesystem in read-write mode: succeeded
Status: CLOSED DUPLICATE of bug 171356
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-22 13:50 EDT by Vaclav "sHINOBI" Misek
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 03:45:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot log from the 1378 kernel. The boot log of the 1380 kernel is identical. (14.79 KB, text/plain)
2005-10-22 16:58 EDT, Sam Varshavchik
no flags Details

  None (edit)
Description Vaclav "sHINOBI" Misek 2005-10-22 13:50:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
My system doesn't start correctly after kernel update to kernel-2.6.12-1.1380_FC3. It freezes just after Remounting root filesystem in read-write mode: succeeded [OK]. Under kernel-2.6.12-1.1378_FC3 it works without problems. The system is updated with the latest updates (released).

lspci -v
00:00.0 Host bridge: Intel Corporation 440LX/EX - 82443LX/EX Host bridge (rev 03)
        Flags: bus master, medium devsel, latency 64
        Memory at e7800000 (32-bit, prefetchable) [size=4M]
        Capabilities: [a0] AGP version 1.0

00:01.0 PCI bridge: Intel Corporation 440LX/EX - 82443LX/EX AGP bridge (rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64

00:04.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 01)
        Flags: bus master, medium devsel, latency 0

00:04.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01) (prog-if 80 [Master])
        Flags: bus master, medium devsel, latency 32
        I/O ports at d800 [size=16]

00:04.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01) (prog-if 00 [UHCI])
        Flags: bus master, medium devsel, latency 32, IRQ 5
        I/O ports at d400 [size=32]

00:04.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 01)
        Flags: medium devsel, IRQ 9

00:09.0 Ethernet controller: Digital Equipment Corporation DECchip 21140 [FasterNet] (rev 12)
        Flags: bus master, medium devsel, latency 32, IRQ 5
        I/O ports at d000 [size=128]
        Memory at e6800000 (32-bit, non-prefetchable) [size=128]

00:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
        Subsystem: Realtek Semiconductor Co., Ltd. RT8139
        Flags: bus master, medium devsel, latency 32, IRQ 12
        I/O ports at b800 [size=256]
        Memory at e6000000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2

00:0b.0 RAID bus controller: Silicon Image, Inc. (formerly CMD Technology Inc) SiI 0649 Ultra ATA/100 PCI to ATA Host Controller (rev 02)
        Subsystem: Silicon Image, Inc. (formerly CMD Technology Inc) SiI 0649 Ultra ATA/100 PCI to ATA Host Controller
        Flags: bus master, medium devsel, latency 64, IRQ 10
        I/O ports at b400 [size=8]
        I/O ports at b000 [size=4]
        I/O ports at a800 [size=8]
        I/O ports at a400 [size=4]
        I/O ports at a000 [size=16]
        Capabilities: [60] Power Management version 2

00:0c.0 VGA compatible controller: S3 Inc. 86c325 [ViRGE] (rev 06) (prog-if 00 [VGA])
        Flags: bus master, medium devsel, latency 32, IRQ 11
        Memory at e0000000 (32-bit, non-prefetchable) [size=64M]
        Expansion ROM at 000c0000 [disabled] [size=64K]

mount
/dev/md1 on / type ext3 (rw)
none on /proc type proc (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/md0 on /boot type ext3 (rw)
none on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)


Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1380_FC3

How reproducible:
Always

Steps to Reproduce:
1. install kernel-2.6.12-1.1380_FC3 and set it as bootup kernel
2. reboot

  

Additional info:
Comment 1 Sam Varshavchik 2005-10-22 16:56:49 EDT
Reporter: please change the hardware field on this bug to "All".

I'm seeing the same bug on a dual x86-64.  Both the SMP and the UP kernel boot
is normal up until the "Remounting root filesystem in read/write mode:" message.

In my case, I do not get the [ OK ] part; the last message on the console is
"Remounting root filesystem in read/write mode: ", exactly.

No other error messages are reported.

In my case, the console responds to a CTRL-C, and resumes booting, but with the
root filesystem still mounted read-only.

I'm also using RAID -- possible common denominator.

Comment 2 Sam Varshavchik 2005-10-22 16:58:36 EDT
Created attachment 120283 [details]
Boot log from the 1378 kernel.  The boot log of the 1380 kernel is identical.
Comment 3 Andreas M. Kirchwitz 2005-10-22 19:53:56 EDT
Same here after updating from previous kernel-2.6.12-1.1378_FC3
to latest kernel-2.6.12-1.1380_FC3. Machine is a Pentium 3
at 600 MHz, ASUS P3B-F motherboard.  Two local IDE disks
running Linux RAID-1 (software), and a additional Adaptec SCSI
host-adapter with only a DVD-ROM connected at the moment.

Last lines of output during boot process are like this:

Checking root filesystem
/dev/md6: clean, ...                            [OK]
Remounting root filesystem in read-write mode:  

And here it hangs. No "[OK]" message. Like Sam, I can hit CTRL-C,
and the machine will continue to boot, but without the other
filesystems and a read-only root filesystems it gives a couple of
error messages from some daemons not able to access stuff in
/var/run and /var/lock and then the machine finally hangs again.

Here's my list of filesystems (made with kernel 2.6.12-1.1378): 
# mount | egrep ^/dev
/dev/md6 on / type ext3 (rw)
/dev/md5 on /boot type ext3 (rw)
/dev/md11 on /home type ext3 (rw)
/dev/md13 on /opt type ext3 (rw)
/dev/md7 on /tmp type ext3 (rw)
/dev/md10 on /usr type ext3 (rw)
/dev/md12 on /usr/local type ext3 (rw)
/dev/md9 on /var type ext3 (rw)

Quite usual setup. RAID-1 created during installation,
using the default GRUB boot loader and the default kernel
options.

However, my default run-level is 3 and not 5 (/etc/inittab)
if this matters.

Any help is appreciated.
Greetings, Andreas
Comment 4 Sam Varshavchik 2005-10-22 22:16:59 EDT
build 1381 from http://people.redhat.com/davej/kernels/Fedora/FC3 boots for me.

Comment 5 Kasper Dupont 2005-10-23 10:51:59 EDT
I have seen this problem as well on a system using the i586 UP kernel. I have
inserted an open -- sulogin command in rc.sysinit to be able to debug this kind
of problem. I found that load average was 1.50 and decreasing, ps -o wchan,args
revealed that the mount command was blocked in sync_page_io. An attempt to cat
/proc/mdstat would block as well, for the cat command wchan showed -.
Comment 6 Davide Bolcioni 2005-10-24 12:59:33 EDT
Over four hosts, two which are using LVM over RAID-1 exhibit the above mentioned
problem; two which are using LVM without RAID-1 work fine. Rebooting with the
1378 kernel was enough.
Comment 7 Jonathan Darton 2005-10-24 17:25:42 EDT
I have the same problem after updating to kernel-smp-2.6.12-1.1380.
The machine is a P4 3GHz with Intel mobo, software RAID 1 with 2 SATA drives.

mount | egrep ^/dev
/dev/md2 on / type ext3 (rw)
/dev/md0 on /boot type ext3 (rw)

The machine would boot if I reverted back to kernel-smp-2.6.12-1.1378.
Comment 8 Dave Jones 2005-10-25 03:45:46 EDT

*** This bug has been marked as a duplicate of 171356 ***

Note You need to log in before you can comment on or make changes to this bug.