Bug 171542 - Request for Enhancement: Ignore packages
Request for Enhancement: Ignore packages
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-22 14:14 EDT by Thijs Hulshof
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 15:16:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thijs Hulshof 2005-10-22 14:14:11 EDT
Description of problem:
It would be great if it was possible to ignore some packages with pup. For
example, I've installed an old version of ndiswrapper, but I don't want it to be
updated because my computer crashes with the newer version.

It is possible to deselect a package, but I don't think that's the best
solution. I prefer the option that up2date has: You can select a package you
never want to update. 

Unfortunately, I don't have developing skills, so I can't help. 

Version-Release number of selected component (if applicable):
pup-0.1.3-1

How reproducible:
It won't be hard to make such an option.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Thanks in advance !
Comment 1 Jeremy Katz 2005-10-22 16:52:43 EDT
You can already do this.  Add an exclude= line to /etc/yum.conf
Comment 2 Thijs Hulshof 2005-10-23 04:47:53 EDT
That's great ! Will there be an option to do this with pup, for user convenience?
Comment 3 David Lawrence 2006-06-27 21:38:23 EDT
Moving component to pirut. Sorry for the spam.
Comment 4 Rahul Sundaram 2006-11-30 16:11:11 EST

I would like to have this option in a preferences portion of pup too. Please
reconsider. 
Comment 5 Jeremy Katz 2007-04-09 15:16:52 EDT
If you get to the point where you know that you're going to not be wanting a
package to be updated, then editing the config file really is the best thing to
do.  Because in most cases, this is because of a bug that we should fix (whether
it's lack of support for hardware leading someone to use ndiswrapper or anything
else)

Note You need to log in before you can comment on or make changes to this bug.