Bug 171547 - icons/gtk-update-icon-cache
icons/gtk-update-icon-cache
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: krusader (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcin Garski
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-22 17:32 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.60.1-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-13 19:18:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2005-10-22 17:32:32 EDT
I know it's icky to have to do something gtk-ish in a kde app, especially the
gtk-update bit(*), but... per
http://fedoraproject.org/wiki/ScriptletSnippets
"GTK+ icon cache", apps that install icons should do (something like):

%post
touch --no-create %{_datadir}/icons/hicolor ||:
gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:

%postun
touch --no-create %{_datadir}/icons/hicolor ||:
gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:

(*) See bug #170335 regarding a request to offload that bit to gtk2.
Comment 1 Marcin Garski 2005-10-25 07:50:51 EDT
I have added gtk-update-icon-cache and also update-mime-database (this one was
also missing), compile went ok on FC 3 and 4.

Durring compile on devel I get error:
libtool: link: cannot find the library `/usr/lib64/libjpeg.la'

This is probably caused by libkjsembed.la from kdebindings, that have reference
to  libjpeg.la, but libjpeg.la was removed since 6b-35. What's strange I've
compiled Krusader in August on devel (previous release) when libjpeg.la was
excluded.

I'll need to examine this more, but I have question to rest of people:
I only have access to FC4, how can I check such errors without access to devel?
Comment 2 Rex Dieter 2005-10-25 08:01:09 EDT
Looks like kdelibs and/or kdebindings needs to be rebuilt to fix the dangling
libtool libjpeg.la reference.

Maybe someday the kde maintainer will see the light to omit the references to
all this extraneous/unnecesssary libtool junk (see bug #170602).
Comment 3 Michael Schwendt 2005-10-25 09:09:23 EDT
> I only have access to FC4, how can I check such errors
> without access to devel?

At present, you can't, since there is no project infrastructure for
test-builds. But you could test-build your package using "mock" and
provided that you have "cheap" access to a Fedora Core/Extras
Development repository.
Comment 4 Marcin Garski 2005-12-13 19:18:17 EST
Finally I have compile Krusader in devel tree, closing bug.
Thanks for report.

Note You need to log in before you can comment on or make changes to this bug.