Bug 171577 - Options "nodateext" and "pattern" are not documented, "pattern" is broken
Options "nodateext" and "pattern" are not documented, "pattern" is broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: logrotate (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-23 12:07 EDT by Mateus César Gröess
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-07 08:37:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mateus César Gröess 2005-10-23 12:07:57 EDT
I was looking in logrotate 3.7.2-9 source and noticed that options "nodateext"
and "pattern" are not documented in man page. Also, option "pattern" is broken
because the function parsePattern should return a pointer to struct
rotatePatternElement, but it returns NULL only.
Comment 1 Mateus César Gröess 2005-11-03 18:52:48 EST
Suggestion: just putting a description in man page for "nodateext" and disabling
the option "pattern" (in readConfigFile) and function "parsePattern" with
"#ifdef 0 ... #endif" would resolve the problem and close this bug ("pattern" is
not documented, anyway).
Comment 2 Peter Vrabec 2005-11-07 08:37:37 EST
logrotate-3.7.2-11

Note You need to log in before you can comment on or make changes to this bug.