Bug 171592 - smp boot crashes with kernel panic message
smp boot crashes with kernel panic message
Status: CLOSED DUPLICATE of bug 169610
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-23 19:54 EDT by Sarah Close
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-27 20:11:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
including /etc/modprobe.conf file (638 bytes, text/plain)
2005-10-26 21:44 EDT, Sarah Close
no flags Details

  None (edit)
Description Sarah Close 2005-10-23 19:54:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040805 Netscape/7.2

Description of problem:
console display as follows::
loading jkd.ko module
loading ext3.ko module
creating root device
mkrootdev:label / not found
mounting root filesystem
mount/: Error 2 mounting ext3
Switching to new root
error opening /dev/console!!!!:2
error dup2ing fd of 0 to 0
error dup2ing fd of 0 to 1
error dup3ing fd of o to 2
unmounting old /proc
unmounting old /sys
switchroot:mount failed:22
kernel panic -  not syncing: attempted to kill init!
[<c0120cd8>] panic+0x45/0x1c4
[<c0121f26>] profile_tasl_exit+0x36/0x4a
[<c0123e7a>] do_exit+0x3a3/0x3f2
[<c01586b87>] do_munmap+0xca/0xf7
[<c0123f22>] do_group_exit+ox29/0x90
[<c010395d>] syscall_call+0x7/0x6

== end of console message display ==

Note: same display for kernel-2.6.13-1.1526_FC4SMP. These 2 versions of the kernel will not boot and panic at the same place every time. Kernel-2.6.12-1.1390_FC4SMP is stable and working on this Dell 650n with dual pentium xeon @ 3.06mhz with u320 scsi disk.

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1532_FC4SMP

How reproducible:
Always

Steps to Reproduce:
1.Select 2.6.13-1.1532_FC4SMP from grub boot menu
2.Wait for the panic message to happen
3.
  

Actual Results:  loading jkd.ko module
loading ext3.ko module
creating root device
mkrootdev:label / not found
mounting root filesystem
mount/: Error 2 mounting ext3
Switching to new root
error opening /dev/console!!!!:2
error dup2ing fd of 0 to 0
error dup2ing fd of 0 to 1
error dup3ing fd of o to 2
unmounting old /proc
unmounting old /sys
switchroot:mount failed:22
kernel panic -  not syncing: attempted to kill init!
[<c0120cd8>] panic+0x45/0x1c4
[<c0121f26>] profile_tasl_exit+0x36/0x4a
[<c0123e7a>] do_exit+0x3a3/0x3f2
[<c01586b87>] do_munmap+0xca/0xf7
[<c0123f22>] do_group_exit+ox29/0x90
[<c010395d>] syscall_call+0x7/0x6


Expected Results:  clean boot to user login.

Additional info:

Dell 650n w/ dual pentium xeon w/ hyperthreading running at 3.06mhz. U320 scsi interface with single 73gb drive. 20 inch lcd monitor on analog port. usb keyboard and mouse.
Comment 1 Dave Jones 2005-10-25 04:35:35 EDT
can you include the contents of your /etc/modprobe.conf please ?
Comment 2 Sarah Close 2005-10-26 21:44:26 EDT
Created attachment 120443 [details]
including /etc/modprobe.conf file
Comment 3 Dave Jones 2005-10-27 20:11:50 EDT

*** This bug has been marked as a duplicate of 169610 ***

Note You need to log in before you can comment on or make changes to this bug.