Bug 171600 - Evolution crashes on startup
Evolution crashes on startup
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-24 02:45 EDT by Russell Coker
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 09:51:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDB information on the crash (5.65 KB, text/plain)
2005-10-24 17:28 EDT, Russell Coker
no flags Details
GDB trace with the debuginfo package installed (5.62 KB, text/plain)
2005-10-24 23:05 EDT, Russell Coker
no flags Details
backtrace from g_logv (3.16 KB, text/plain)
2005-10-25 17:38 EDT, Russell Coker
no flags Details

  None (edit)
Description Russell Coker 2005-10-24 02:45:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051008 Fedora/1.5-0.5.0.beta2 Firefox/1.4.1

Description of problem:
Crashes with the following messages on stdout/stderr at startup:

$ evolution
adding hook target 'source'

(evolution:3498): camel-WARNING **: camel_exception_get_id called with NULL para
meter.

(evolution:3498): Gdk-CRITICAL **: gdk_gc_set_foreground: assertion `GDK_IS_GC (                                                                                                                                                    gc)' failed

(evolution:3498): camel-WARNING **: Could not find key entry for word 'sysv00000                                                                                                                                                    000': Success


(evolution:3498): camel-WARNING **: Could not find key entry for word '00000000'                                                                                                                                                    : Success


(evolution:3498): camel-WARNING **: Could not find key entry for word '000000010                                                                                                                                                    0000000': Success


(evolution:3498): camel-WARNING **: Could not find key entry for word '000000000                                                                                                                                                    0000000': Success


(evolution:3498): camel-WARNING **: Could not find key entry for word '0x0000000                                                                                                                                                    0': Success


(evolution:3498): camel-CRITICAL **: camel_folder_free_message_info: assertion `                                                                                                                                                    info != NULL' failed


Version-Release number of selected component (if applicable):
2.4.1-4

How reproducible:
Always

Steps to Reproduce:
I just start Evolution from the GUI or from the command-line.

Additional info:
Comment 1 Dave Malcolm 2005-10-24 13:44:24 EDT
Thanks for this report.

That package works for me.  Please can you install the debuginfo packages for
evolution and e-d-s, try running evolution under gdb, and submit a backtrace
(using "t a a bt" to get all threads).  Thanks.
Comment 2 Russell Coker 2005-10-24 17:28:45 EDT
Created attachment 120323 [details]
GDB information on the crash
Comment 3 Dave Malcolm 2005-10-24 18:52:36 EDT
Thanks.

It's crashing in thread 5 in one of the camel backends (handling mail stored
locally, e.g. mbox or maildir)

What does "rpm -q evolution-data-server" say?

Please can you install evolution-data-server-debuginfo, and regenerate a
backtrace.  Thanks.
Comment 4 Russell Coker 2005-10-24 23:05:58 EDT
Created attachment 120337 [details]
GDB trace with the debuginfo package installed
Comment 5 Dave Malcolm 2005-10-25 12:52:04 EDT
Thanks.  So it's reading through a NULL camel_index pointer when refreshing an
account based on a local mbox file.

What may have happened is that the index file has somehow got corrupt, and the
loader is failing.

The message:
(evolution:3498): camel-CRITICAL **: camel_folder_free_message_info: assertion `
                                                                               
                                                                   info != NULL'
failed
suggests this as well.  If you put a breakpoint on g_logv it may be helpful to
get a backtrace at the point where this is output (and then we can hopefully fic
this bug, rather than patching around it...)

As a workaround, try quitting evolution, navigating to the folder below the
~/.evolution/mail/local directory and moving away the .index file, then
restarting evolution - does that help?
Comment 6 Russell Coker 2005-10-25 17:38:39 EDT
Created attachment 120389 [details]
backtrace from g_logv

This is a backtrace from where g_logv is called before the crash proper.
Comment 7 Russell Coker 2005-10-25 17:45:21 EDT
I moved the file Inbox.ibex.index, it was re-created identically and Evolution
crashed again.  Incidentally that file was 1024 bytes in size.

I just recalled that recently I changed a setting to have Evolution index the
bodies of messages, the first crash may have been the first time I restarted it
after changing that setting.

Comment 9 Dave Malcolm 2005-10-25 19:29:29 EDT
Thanks: can you specify which setting you're referring to in comment 7?  Does
changing it back help?
Comment 10 Russell Coker 2005-10-25 23:16:26 EDT
I have just discovered that removing the file Inbox.ibex.index.data is the
solution (or work-around) for the problem.  Would you like the file as a private
attachment?
Comment 12 Matthew Barnes 2006-12-31 11:50:08 EST
Does this problem still exist in Fedora Core 6?
Comment 14 Need Real Name 2007-01-02 13:45:18 EST
Evolution still crashes on startup for me. About 30% of the time.

Note You need to log in before you can comment on or make changes to this bug.