Bug 171615 - kernel rc5-git3 crashing at various stages
kernel rc5-git3 crashing at various stages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-24 09:14 EDT by Sammy
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 16:21:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output (1.74 KB, text/plain)
2005-10-25 10:06 EDT, Sammy
no flags Details
lspci output (1.74 KB, text/plain)
2005-10-25 10:07 EDT, Sammy
no flags Details

  None (edit)
Description Sammy 2005-10-24 09:14:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux; X11; en_US) KHTML/3.4.92 (like Gecko)

Description of problem:
Updating from 1621 to 1624 is causing various panics and memory errors. 
Kernel 1621 is working fine still. Sometimes I get panic during boot after 
devices are detected, and sometimes it survives until graphical login and 
freezes afterwards. 

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1624_FC5

How reproducible:
Always

Steps to Reproduce:
1. Boot 1624 on X86_64 SMP system. 
2. try to use the computer! 
3. 
   

Additional info:
Comment 1 Sammy 2005-10-24 10:08:20 EDT
Confirmed same behavior with 1.1623 kernel. In addition to being 
on X86_64 SMP system I am using U320 SCSI disk with the Adaptec 
driver. 
Comment 2 Dave Jones 2005-10-24 22:26:22 EDT
can you capture (at least) one of those panics ? It may give some clues.
Comment 3 Dave Jones 2005-10-24 22:56:22 EDT
it'll also be interesting to know what hardware is in this box, to compare with
bug 171632 which sounds similar.
Comment 4 Dave Jones 2005-10-25 00:44:50 EDT
in an attempt to narrow this down, I've built 1626 without the powernow driver,
as thats my current strongest suspect. Can you grab the kernel at
http://people.redhat.com/davej/kernels/Fedora/devel and see if that works for you?

(It'll also go out to rawhide tomorrow if you don't read this before then, in
which case you can just 'yum update' to get it).
Comment 5 Sammy 2005-10-25 10:06:23 EDT
Created attachment 120358 [details]
lspci output
Comment 6 Sammy 2005-10-25 10:07:41 EDT
Created attachment 120362 [details]
lspci output
Comment 7 Sammy 2005-10-25 10:13:30 EDT
Sorry, 1.1626 panics too. It goes through the initrd stage, disks etc are
found correctly. It is panicing at various stages of initscripts output.
Sometimes it may even go all the way through.

When it panics it has calls to syscal vsyscal ext3 etc as the last few items
on the screen.

This is a DELL Precision 380n with dual-core extreme edition Pentium 840 at
3.20 GHz and with 4Gb of ram. I have disabled hyperthreading. I am running
rawhide X86_64. Updated daily. 

Again it works fine with 1.1621.
Thanks
Comment 8 Sammy 2005-10-25 12:48:36 EDT
I recompiled 1.1626 with git5 as well as removing hugetlb and selinux patches 
from the git5 patch. It did last two minutes longer but crashed again. 
 
Looking at the other machine I see ieee1394 common but did not see any patches 
since rc5 to effect that. 
 
By the way I am always getting the following error line (also with 1.1621): 
 
kernel: hald-probe-smbi[2589] trap stack segment rip:401147 rsp:7fffffdaaab0 error:0 
Comment 9 Sammy 2005-10-26 09:31:13 EDT
I noticed that others seem to have AMD cpu's I have an Intel cpu, so this is not an AMD 
problem. 
 
# cat /proc/cpuinfo 
processor       : 0 
vendor_id       : GenuineIntel 
cpu family      : 15 
model           : 4 
model name      :               Intel(R) Pentium(R) D CPU 3.20GHz 
stepping        : 4 
cpu MHz         : 3192.138 
cache size      : 1024 KB 
physical id     : 0 
siblings        : 2 
core id         : 0 
cpu cores       : 1 
fpu             : yes 
fpu_exception   : yes 
cpuid level     : 3 
wp              : yes 
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 
clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall lm constant_tsc pni monitor ds_cpl cid 
cx16 xtpr 
bogomips        : 6390.65 
clflush size    : 64 
cache_alignment : 128 
address sizes   : 36 bits physical, 48 bits virtual 
power management: 
 
processor       : 1 
vendor_id       : GenuineIntel 
cpu family      : 15 
model           : 4 
model name      :               Intel(R) Pentium(R) D CPU 3.20GHz 
stepping        : 4 
cpu MHz         : 3192.138 
cache size      : 1024 KB 
physical id     : 0 
siblings        : 4 
core id         : 1 
cpu cores       : 2 
fpu             : yes 
fpu_exception   : yes 
cpuid level     : 5 
wp              : yes 
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 
clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall lm constant_tsc pni monitor ds_cpl cid 
cx16 xtpr 
bogomips        : 6384.20 
clflush size    : 64 
cache_alignment : 128 
address sizes   : 36 bits physical, 48 bits virtual 
power management: 
 
 
Comment 10 Sammy 2005-10-26 12:41:34 EDT
Dave, in 1.1627 spec file I see the %patch1 (git patch) commented out! 
Is this back to pure rc5 or has this been the case before? 
Comment 11 Sammy 2005-10-26 12:49:40 EDT
I meant patch2 commented. 
Comment 12 Sammy 2005-10-26 16:32:59 EDT
I tried git6+the latest patches with the same result (hangs at swap). I also  noticed the 
following messages during the last stages of build: 
 
Scanning objects 
Error: ./arch/i386/kernel/cpu/cpufreq/powernow-k8.o .data refers to 
0000000000000020 R_X86_64_64       .init.text+0x0000000000000069 
Error: ./arch/x86_64/kernel/cpufreq/powernow-k8.o .data refers to 0000000000000020 
R_X86_64_64       .init.text+0x0000000000000069 
Error: ./arch/x86_64/kernel/mce.o .text refers to 0000000000000a7e 
R_X86_64_PC32     .init.data+0x000000000000000c 
Error: ./arch/x86_64/kernel/setup64.o .text refers to 000000000000012f 
R_X86_64_PC32     .init.data+0x0000000000000ffb 
Error: ./drivers/video/vesafb.o .data refers to 00000000000003a0 
R_X86_64_64       .init.text 
Error: ./init/main.o .text refers to 00000000000001d5 
R_X86_64_PC32     .init.data+0x000000000000015f 
Done 
 
Comment 13 Sammy 2005-10-26 20:31:37 EDT
I am looking at the cvs spec file for 1.1629_FC5 and I still see 
 
#%patch2 -p1 
 
i.e. git patch application commented out. Am I missing something? 
Comment 14 Sammy 2005-10-27 10:59:26 EDT
Picking up the 1.1629 source rpm and actually applying git7 patch again froze 
the system after a few minutes of working (this is using the config for 1.1629). 
It did go through the initscripts stage and I actually logged in for a few minutes. 
FYI 
Comment 15 Dave Jones 2005-10-27 19:28:59 EDT
the commented out %patch was an oversight that has been corrected in the 1630
kernel. (Available at http://people.redhat.com/davej/kernels/Fedora/devel/ or
tomorrows rawhide).

The random crashes that others saw were fixed in 1629 when I disabled
CONFIG_OPTIMIZE_FOR_SIZE.  Did you have this enabled in your local build perhaps ?

Note You need to log in before you can comment on or make changes to this bug.