Bug 171632 - Boot hangs in "Enabling swap space"
Boot hangs in "Enabling swap space"
Status: CLOSED DUPLICATE of bug 171672
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-24 12:06 EDT by Horst H. von Brand
Modified: 2015-01-04 17:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-27 19:23:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of lspci on the affected machine (1.66 KB, text/plain)
2005-10-25 10:08 EDT, Horst H. von Brand
no flags Details
Contents of /proc/cpuinfo (628 bytes, text/plain)
2005-10-25 10:09 EDT, Horst H. von Brand
no flags Details
lspci output (1.37 KB, text/plain)
2005-10-26 01:59 EDT, Brian Gerst
no flags Details
my lspci -vvv output (22.59 KB, text/plain)
2005-10-26 19:13 EDT, Willem Riede
no flags Details

  None (edit)
Description Horst H. von Brand 2005-10-24 12:06:09 EDT
Description of problem:
The system hangs when enabling swap space. Swap is on a LVM volume here.

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1624_FC5

How reproducible:
Always

Steps to Reproduce:
1. Boot, preferably with no rhgb to see it hang
2.
3.
  
Actual results:
Hang when "Enabling swap space"

Expected results:
Normal boot

Additional info:
kernel-2.6.13-1.1621_FC5 works fine. System up to date as of today.
Comment 1 Horst H. von Brand 2005-10-24 12:22:53 EDT
kernel-2.6.13-1.1623_FC5 hangs the same
Comment 2 Dave Jones 2005-10-24 22:55:53 EDT
What hardware is in this box ? I wonder because 171615 sounds similar, and I
wonder if there's a common item between the two bugs.
Comment 3 Dave Jones 2005-10-25 00:44:51 EDT
in an attempt to narrow this down, I've built 1626 without the powernow driver,
as thats my current strongest suspect. Can you grab the kernel at
http://people.redhat.com/davej/kernels/Fedora/devel and see if that works for you?

(It'll also go out to rawhide tomorrow if you don't read this before then, in
which case you can just 'yum update' to get it).
Comment 4 Horst H. von Brand 2005-10-25 10:08:26 EDT
Created attachment 120364 [details]
Output of lspci on the affected machine
Comment 5 Horst H. von Brand 2005-10-25 10:09:33 EDT
Created attachment 120366 [details]
Contents of /proc/cpuinfo
Comment 6 Horst H. von Brand 2005-10-25 14:06:48 EDT
kernel-2.6.13-1.1626_FC5 hangs the same.

Will do the bisection Linus suggested, but it will take some setting up.
Comment 7 Brian Gerst 2005-10-26 01:58:11 EDT
1627 still hangs for me.

processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 31
model name      : AMD Athlon(tm) 64 Processor 3000+
stepping        : 0
cpu MHz         : 1809.281
cache size      : 512 KB
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow
lahf_lm
bogomips        : 3622.49
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp
Comment 8 Brian Gerst 2005-10-26 01:59:43 EDT
Created attachment 120397 [details]
lspci output
Comment 9 Horst H. von Brand 2005-10-26 17:40:05 EDT
Again, kernel-2.6.13-1.1627_FC5 hangs.
i686 works fine.

I did the bisection suggested by Linus, and came up empty-handed: The latest
vanilla kernel from git, compiled with FC's .config (sans CONFIG_INFO) works
fine, as did every kernel I tried.
Comment 10 Willem Riede 2005-10-26 19:10:52 EDT
I experience the same hang, at least with 1624, 1626 and 1627.
This is x86_64 on dual-core opteron.
I will attach lspci output next.

processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 33
model name      : Dual Core AMD Opteron(tm) Processor 270
stepping        : 2
cpu MHz         : 1000.019
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext
3dnow pni lahf_lm cmp_legacy
bogomips        : 2002.15
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp

processor       : 1
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 33
model name      : Dual Core AMD Opteron(tm) Processor 270
stepping        : 2
cpu MHz         : 1000.019
cache size      : 1024 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt lm 3dnowext
3dnow pni lahf_lm cmp_legacy
bogomips        : 2002.15
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 40 bits physical, 48 bits virtual
power management: ts fid vid ttp

Comment 11 Willem Riede 2005-10-26 19:13:36 EDT
Created attachment 120438 [details]
my lspci -vvv output
Comment 12 Horst H. von Brand 2005-10-27 13:38:41 EDT
kernel-2.6.13-1.1629_FC5 boots OK here.
Comment 13 Willem Riede 2005-10-27 17:39:31 EDT
1629 boots for me too.
Comment 14 Dave Jones 2005-10-27 19:23:53 EDT

*** This bug has been marked as a duplicate of 171672 ***

Note You need to log in before you can comment on or make changes to this bug.