Bug 171633 - [LSI 4.8 feat] ipv6 support needs to be added to userpace tools
[LSI 4.8 feat] ipv6 support needs to be added to userpace tools
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Christie
: FutureFeature, OtherQA
Depends On:
Blocks: 445361 458123
  Show dependency treegraph
Reported: 2005-10-24 12:06 EDT by Mike Christie
Modified: 2009-06-18 10:22 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-08-26 08:40:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mike Christie 2005-10-24 12:06:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Currently iscsi tools and the driver only support ipv4. Cisco is releasing ipv6 support in its targets and would like the iscsi tools and driver to support it. This bugzilla is for the addition of ipv6 support to the userspce iscsi tools. The driver bugzilla is here https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=167555

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. run tools
2. no ipv6 support

Additional info:
Comment 6 Vamsi Krishna Sadhu 2006-09-11 02:05:39 EDT
I have given some more support for the IPV6 at user space and kernel space 
level,that will inturn contains sending ipv6 info to the kernel and there it 
will distinguish between IPV4/6 and then get connect.

In case if you need the patch, i will send that across to you.
Comment 8 RHEL Product and Program Management 2007-03-09 20:12:40 EST
This bugzilla had previously been approved for engineering
consideration but Red Hat Product Management is currently reevaluating
this issue for inclusion in RHEL4.6.
Comment 11 Andrius Benokraitis 2007-08-23 13:31:11 EDT
This has been deferred to RHEL 4.7 due to resource constraints and the stated
medium severity.
Comment 13 Andrius Benokraitis 2008-05-06 10:13:49 EDT
This has been deferred to RHEL 4.8 due to just receiving hardware and firmware
to test this.
Comment 15 RHEL Product and Program Management 2008-08-26 08:40:12 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.