Bug 171644 - kernel-xen conflicts with kudzu
kernel-xen conflicts with kudzu
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Juan Quintela
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-24 13:42 EDT by Roy-Magne Mo
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-14 00:08:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roy-Magne Mo 2005-10-24 13:42:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051008 Fedora/1.5-0.5.0.beta2 Firefox/1.4.1

Description of problem:
The new kernel-xen package won't install since it conflicts with current kudzu package:

# yum --enablerepo=development --enablerepo=extras-development install kernel-xen-guest kernel-xen-hypervisor
Setting up Install Process
Setting up repositories
development               100% |=========================| 1.1 kB    00:00
extras                    100% |=========================| 1.1 kB    00:00
extras-development        100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 950 kB    00:03
extras    : ################################################## 2659/2659
Added 17 new packages, deleted 0 old in 14.44 seconds
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package kernel-xen-guest.i686 0:2.6.12-1.4_FC5 set to be installed
---> Package kernel-xen-hypervisor.i686 0:2.6.12-1.4_FC5 set to be installed
--> Running transaction check
--> Processing Conflict: kudzu conflicts kernel < 2.6.13
--> Finished Dependency Resolution
Error: kudzu conflicts with kernel < 2.6.13


Version-Release number of selected component (if applicable):
kudzu-1.2.9-1 kernel-xen-guest-2.6.12-1.4_FC5 kernel-xen-hypervisor-2.6.12-1.4_FC5

How reproducible:
Always

Steps to Reproduce:
1. yum --enablerepo=development --enablerepo=extras-development install kernel-xen-guest kernel-xen-hypervisor
2.
3.
  

Additional info:
Comment 1 Arjan van de Ven 2005-10-24 13:59:51 EDT
one can argue that it's not kernel-xen that conflicts with kudzu, but kudzu that
conflicts with kernel-xen... ;)
Comment 2 Roy-Magne Mo 2005-10-24 14:38:42 EDT
(In reply to comment #1)
> one can argue that it's not kernel-xen that conflicts with kudzu, but kudzu that
> conflicts with kernel-xen... ;)

yes we could, but kernel-xen is the new kid on the block here :) 
Comment 3 Stephen Tweedie 2006-01-14 00:08:46 EST
It installs now.  (Kudzu SEGVs on dom0, true, but that's a separate bug...)

Note You need to log in before you can comment on or make changes to this bug.