Bug 171647 - vncviewer wrongly translates keyboard
vncviewer wrongly translates keyboard
Status: CLOSED DUPLICATE of bug 201927
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-24 14:02 EDT by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-08 05:28:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-10-24 14:02:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Epiphany/1.6.5

Description of problem:
Connecting to a VNC server that uses a German keyboard, from a computer with vncviewer that uses a German keyboard, gives the wrong characters when typing.

This only occurs for special characters.
e.g. what is "-" on my keyboard appears as "§" on the screen.

ssh has no such problem.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Need Real Name 2005-10-24 14:06:09 EDT
And bugzilla has converted the special character (shall I log a bug?)

It should be a "spicy S", i.e. the German character for ss in some words.

e.g. http://www.dict.cc/?s=Stra%DFe (follow link)
Comment 2 Jitka Kozana 2006-01-27 02:32:14 EST
Could you please tell me the vnc version you are using?  
What does the "rpm -q vnc" say? 
  
Comment 3 Need Real Name 2006-02-06 18:11:15 EST
I can no longer reproduce this, however I am now going from rawhide to FC4,
rather than FC4 to FC4.
Comment 4 Jitka Kozana 2006-03-08 05:28:44 EST
I've tried to reproduce the bug with vnc-4.1.1-36, and I can write ß, as well  
as other national characters without any problems.  
 
If this bug reoccurs, feel free to reopen this bug.  
Comment 5 Need Real Name 2006-08-09 16:20:53 EDT

*** This bug has been marked as a duplicate of 201927 ***

Note You need to log in before you can comment on or make changes to this bug.