Bug 17169 - X config causes system to hang, HW detected OK
X config causes system to hang, HW detected OK
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-01 05:37 EDT by Gerwin Jansen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 23:37:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gerwin Jansen 2000-09-01 05:37:19 EDT
Hi,

I'm using this videocard:

Diamond Stealth II / S220 with Rendition Verite 2100 chipset and 4Mb of 
memory

together with this display:

Philips 107B (CM6800).

These are detected by the setup of RH linux 6.2 as:

- Rendition 2x00 chipset and
- DDC 107 monitor (last in list)

If I leave this the way it is, the probe that follows makes my system hang 
(screen black, display does not to into sleep mode, display is set to 
720x400)

If I change the detected values to match my configuration (Diamond Stealth 
II / S220, Philips 107B (CM6800)), same happens: system hangs, screen 
black.

All I can do is reboot by pressing reset button.

Please advise.
Comment 1 Trond Eivind Glomsrxd 2000-10-17 18:14:37 EDT
This must have been in the installer, as Xconfigurator didn't have DDC probing
at the time
Comment 2 Brent Fox 2000-10-31 09:48:01 EST
Please verify this against Red Hat Linux 7 and let us know if that works.  RHL 7
comes with XFree86 4.0, which may resolve this issue.
Comment 3 Gerwin Jansen 2000-11-06 06:30:31 EST
Last week, I downloaded RH7 and tried again. The problem I experience has not been solved.

The screen resolution keeps changing to 720x400 whenever the X configuration is tested. I tried the automatic probe as well as the manual ones, I tried 
1024x768x16 and 1024x768x8. These are modes that should be easilly possible with the S220 4Mb card.

Is there any other way I can try / debug this and see why this is happening?
Comment 4 Brent Fox 2000-11-06 09:25:53 EST
Try going to the 2nd virtual console by pressing <Ctl><Alt><F2> and enter the
command lspci -v
You'll see a lot of info about the hardware in your system like soundcard,
ethernet, and video card.  If you can tell us the information that pertains to
your video card, we could at least know if the card is correctly identified.

A workaround for the time being is to skip X configuration in the installer. 
Once the install is finished, run Xconfigurator.  This *should* allow your video
card to work.
Comment 5 Brent Fox 2000-11-06 11:17:25 EST
Also, is the installer coming up in graphical mode or text mode when it starts?
From looking at the Red Hat Hardware Compatibility List 
( http://hardware.redhat.com/redhatready/cgi-bin/us/db-hcl.cgi search for
Diamond) , it appears that the Diamond Stealth II / S220 is not officially
supported, so that could be where the problem probing the card comes from. 
That's not to say that the card won't work...it's just not one that we
officially support.
Comment 6 Gerwin Jansen 2000-11-07 17:31:27 EST
I've added the results of 'lspci -vv' below. The only way for me to install RH7 is skipping X (yes I know the S220 is not on the RHHCL).

The installer _does_ run in graphical mode but whenever <Ctrl><Alt><F2> is tried, the lockup immediately occurs (720x400 res.).

Here are the results of lspci: (hope this helps any, suggestions welcome!)

00:00.0 Host bridge: Intel Corporation 430VX - 82437VX TVX [Triton VX] (rev 02)
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
	Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR-
	Latency: 32

00:07.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II] (rev 01)
	Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
	Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
	Latency: 0

00:07.1 IDE interface: Intel Corporation 82371SB PIIX3 IDE [Natoma/Triton II] (prog-if 80 [Master])
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
	Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
	Latency: 32
	Region 4: I/O ports at f000

00:11.0 SCSI storage controller: Adaptec AHA-7850 (rev 01)
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
	Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
	Latency: 32 (1000ns min, 1000ns max), cache line size 08
	Interrupt: pin A routed to IRQ 10
	Region 0: I/O ports at 6000
	Region 1: Memory at e2040000 (32-bit, non-prefetchable)

00:12.0 Multimedia video controller: 3Dfx Interactive, Inc. Voodoo 2 (rev 02)
	Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
	Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
	Region 0: Memory at e0000000 (32-bit, prefetchable)

00:13.0 VGA compatible controller: Rendition Verite V2000/V2100/V2200 (rev 02) (prog-if 00 [VGA])
	Subsystem: Diamond Multimedia Systems Stealth II S220
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
	Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
	Latency: 32, cache line size 08
	Interrupt: pin A routed to IRQ 9
	Region 0: Memory at e1000000 (32-bit, prefetchable)
	Region 1: I/O ports at 6500
	Region 2: Memory at e2000000 (32-bit, non-prefetchable)
	Capabilities: [60] AGP version 1.0
		Status: RQ=0 SBA- 64bit- FW- Rate=x1
		Command: RQ=0 SBA- AGP- 64bit- FW- Rate=x1

00:14.0 Ethernet controller: 3Com Corporation 3c900 Combo [Boomerang]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
	Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
	Latency:32 (750ns min, 2000ns max)
	Interrupt: pin A routed to IRQ 9
	Region 0: I/O ports at 6600
Comment 7 Brent Fox 2000-11-13 17:32:31 EST
Hmmm...well, looking at your output from lspci, it appears that the video card
and the Ethernet controller are both on IRQ 9.  That could be the cause of the
problem.  I would suggest going into the BIOS of your system and trying to
assign different IRQ's to the devices.

Note You need to log in before you can comment on or make changes to this bug.