Bug 1717031 - erlang-eflame: could not rebuild with Perl 5.30 due to cycle
Summary: erlang-eflame: could not rebuild with Perl 5.30 due to cycle
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: erlang-eflame
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL: http://apps.fedoraproject.org/koschei...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-06-04 14:54 UTC by Jitka Plesnikova
Modified: 2019-06-06 11:33 UTC (History)
1 user (show)

Fixed In Version: erlang-eflame-0-0.13.gita085181.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-06 11:33:33 UTC
Type: Bug


Attachments (Terms of Use)
root.log from failed build (59.62 KB, text/plain)
2019-06-04 14:54 UTC, Jitka Plesnikova
no flags Details

Description Jitka Plesnikova 2019-06-04 14:54:49 UTC
Created attachment 1577157 [details]
root.log from failed build

I was not able to rebuild erlang-eflame with Perl 5.30, because there is a dependency cycle. Is there any way how to solve it?

Error from root.log:
DEBUG util.py:583:  BUILDSTDERR: Error: 
DEBUG util.py:583:  BUILDSTDERR:  Problem: package erlang-rebar-2.6.4-9.fc30.noarch requires erlang-eflame, but none of the providers can be installed
DEBUG util.py:583:  BUILDSTDERR:   - conflicting requests
DEBUG util.py:583:  BUILDSTDERR:   - nothing provides perl(:MODULE_COMPAT_5.28.1) needed by erlang-eflame-0-0.11.gita085181.fc31.noarch
DEBUG util.py:585:  (try to add '--skip-broken' to skip uninstallable packages)


https://koji.fedoraproject.org/koji/buildinfo?buildID=1273542

Comment 1 Peter Lemenkov 2019-06-05 12:56:48 UTC
I'll take care of this one.

Comment 2 Jitka Plesnikova 2019-06-05 13:01:47 UTC
Perl 5.30 should be merge to rawhide later today. 

https://pagure.io/releng/issue/8384

Comment 3 Peter Lemenkov 2019-06-06 11:33:33 UTC
Done (rebootstrapped it) in erlang-eflame-0-0.13.gita085181.fc31.


Note You need to log in before you can comment on or make changes to this bug.