Bug 171803 - rpm 4.2.3 fails with debug info when building java app
rpm 4.2.3 fails with debug info when building java app
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-26 13:34 EDT by Don Seiler
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:52:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample spec file that nasrat made (573 bytes, text/plain)
2005-10-26 13:34 EDT, Don Seiler
no flags Details

  None (edit)
Description Don Seiler 2005-10-26 13:34:00 EDT
nasrat in #rpm confirmed this.

Using rpmbuild 4.2.3 to package a java app.  When building, rpmbuild would fail
with this error:

error: line 28: Too many names: %files debuginfo -f debugfiles.list
'/usr/bin/rpmbuild' failed with exit code 1

I will attach sample .spec file that nasrat made that also duplicates problem. 
Workaround was to either stop debug info via this:

%define debug_package %{nil}

Or to specify 'noarch' via the BuildArch header:

BuildArch: noarch

In my case I probably should have been using noarch anyway, since it is a java
app.  Regardless nasrat confirmed that this is a bug.  I'm filing here for
public viewing and will file with our official RHEL support as well.
Comment 1 Don Seiler 2005-10-26 13:34:01 EDT
Created attachment 120424 [details]
sample spec file that nasrat made
Comment 2 Don Seiler 2005-10-26 13:35:31 EDT
Forgot to note that my spec file works as-is on rpm-4.0.4.  I just encountered
the problem when trying to build on this newer box with 4.2.3.
Comment 3 Jeff Johnson 2005-11-13 21:26:25 EST
Reproducer fails on FC5:
...
Executing(%build): /bin/sh -e /X/tmp/rpm-tmp.36628
+ umask 022
+ cd /X/javatest
+ cd javatest-1.0
+ javac $'hello.java\r'
File hello.java is missing
error: Bad exit status from /X/tmp/rpm-tmp.36628 (%build)


RPM build errors:
    Bad exit status from /X/tmp/rpm-tmp.36628 (%build)
Comment 4 Jeff Johnson 2005-11-13 21:27:28 EST
Reproducer fails on FC5:
...
Executing(%build): /bin/sh -e /X/tmp/rpm-tmp.36628
+ umask 022
+ cd /X/javatest
+ cd javatest-1.0
+ javac $'hello.java\r'
File hello.java is missing
error: Bad exit status from /X/tmp/rpm-tmp.36628 (%build)


RPM build errors:
    Bad exit status from /X/tmp/rpm-tmp.36628 (%build)
Comment 5 Paul Nasrat 2005-11-14 05:22:37 EST
Jeff - that looks like newline breakage in the specfile - dos2unix should fix.

That actually builds here on rawhide, the bug is against rpm 4.2.3 for RHEL3
Comment 6 Paul Nasrat 2006-08-08 17:58:12 EDT
Don - did you ever file a support request, I don't see one linked against here.
 Support requests are used in the prioritisation of tasks for update releases.
Comment 7 Don Seiler 2006-08-14 11:03:03 EDT
I thought I did.  I can't find anything on my end to support that claim though.
 I can do it now if you'd like.
Comment 8 Paul Nasrat 2006-08-14 11:08:53 EDT
That would be useful to ensure that it can be considered appropriately.
Comment 9 Don Seiler 2006-10-11 16:07:20 EDT
Well I was all logged in and ready to file a Web Support ticket, but now I can't
duplicate this error on any of the java apps that I normally build.  The box
currently has rpm-4.2.3-30_nonptl installed.

Paul can you duplicate with your sample .spec?
Comment 10 RHEL Product and Program Management 2007-10-19 14:52:00 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.