Bug 171851 - imap breaks Outlook 2002
imap breaks Outlook 2002
Status: CLOSED DUPLICATE of bug 171852
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dovecot (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Depends On:
  Show dependency treegraph
Reported: 2005-10-26 20:24 EDT by Orion Henry
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-19 07:41:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Orion Henry 2005-10-26 20:24:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.7 (KHTML, like Gecko) Safari/412.5

Description of problem:
Moved my mail server over from debian + courier-imap + maildir to RHEL 4 + dovecot-imap + maildir 
and has huge problems with Outlook 2002 clients.  The problems were hard to pin down but luckily the 
soltion was easy.  Of about 60 users of Outlook 2002 about 10 were having serious problems. They 
came in several forms

1) Outlook would said that the Group ID had changed on the message unexpectidaly and shut down.  
This could be fixed by deleteing the indexes in that users folders.
2) Outlook would run VERY VERY slowly.  I tried removing the indexes and noticed that they were NOT 
rebuilt when outlook accessed them telling me that Outlook was somehow not using them at all
3) Outlook would crash about 3 seconds after connecting to the imap server.
4) Outlook would hang when trying to connect to the imap server and would have to "End Task'ed"
5) Outlook freaked out and deleted a outlook.pst file.  Yikes!

More people were running into problems every day and new breeds of problems were cropping up left 
and right.  The good news is is that installing dovecot 0.99.14-1 fixed all of these problems.  

The only issues I had upgrading to 0.99.14-1 were (1) it moved my dovecot.conf to 
dovecot.conf.rpmsave and (2) the default folders for ssl_cert_file and ssl_key_file had changed and 
needed to be specified.

Please please please get dovecot-0.99.14-1 moved downstream so I don't have to be running a out-of-
spec RH install and I'm sure others out there are having the same problems as me.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. setup dovecot + imap
2. use maildir
3. access it with Outlook 2002 (25% chance of it breaking)

Actual Results:  Outlook 2002 would crash, hang, or run very very slowly.

Expected Results:  Outlook 2002 would run quickly and not crash.

Additional info:

Just upgrade dovecot to 0.99.14-1.  This fixes it.
Comment 1 Petr Rockai 2006-01-19 07:41:11 EST

*** This bug has been marked as a duplicate of 171852 ***

Note You need to log in before you can comment on or make changes to this bug.