Bug 171864 - realtek 8139 achieve timeout
realtek 8139 achieve timeout
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-27 04:06 EDT by Massimo Nicolini
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-01 13:56:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Massimo Nicolini 2005-10-27 04:06:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050727

Description of problem:
I've recently bought an HP Pavilion zv6181 notebook with an AMD Athlon 64 bit and a Realtek 8139 network card on board.
When a do lspci i can see the network card is a Realtek and the subsystem is HP.
I've installed a "normal" Fedora 4 ( not X86_64 due to timer problems ) but when i try to ping any other PC ( i've tried using cross cable, switch, hub.... on the same lan ) i give remote MAC/IP pairing ( often but not always ) and when it happens i can see icmp echo request packets but no one echo reply go away from my network card.
Remote PCs ( i've tried with many ) cannot achieve my MAC/IP pairing; when it happens ( every two PCs have right MAC ) ping sequence starts with very irregular TTL ( from 1 ms to 50000ms ) and then stops loosing MAC/IP pairing for a long amount of time.
My iptables is empty with ACCEPT as default rule.I've made tests using ifplugd and any other arp servicies up and/or down without any significant result.

I've done these tests:
1) Using a PCMCIA 3Com card i can use network perfectly.
2) Using a PCMCIA Realtek card the problem is always the same.
3) My system is dual boot, so when i use Windows on board Realtek works.
4) I've downloaded all fc4 kernels, but the problem persists.
5) i've downloaded a vanilla Kernel, compiled with 8139 statically linked code and the on board 8139 WORKS PERFECTLY, BUT WHEN I TRY TO SEE A DVD USING VIDEOLINE CLIENT ( THE ONLY ONE MEDIA PLAYER THAT WORKS FINE ON MY SYSTEM ) I MISS SO MANY FRAMES THAT'S IMPOSSIBLE TO SEE ANYTHING AND AUDIO MODULE (snd-atiixp.ko) CANNOT BE LOADED SO I CANNOT HEAR ANYTHING.
6) i've downloaded a fc4 526 Kernel, deleted 8139 patch and tried many 8139 compilation option ( pio, old reset, and so on ) with non results.

Note: kernel detect rightly the 8139 card and no error messages appear in /var/log/messages.
In /var/log/messages i can see with ifplugd activated that sometimes eth0 hangs due a timeout.

Version-Release number of selected component (if applicable):
Any recent

How reproducible:
Always

Steps to Reproduce:
1.Simply connect a network cable to on board network card.
2.
3.
  

Actual Results:  I give the connection ploblem descibed above

Expected Results:  Network ok, not ko

Additional info:
Comment 1 Massimo Nicolini 2005-10-28 04:47:01 EDT
I've unpatched kernel-2.6.13-1.1532_FC4.src.rpm with xen patches, but problem
persist.
Comment 2 John W. Linville 2005-10-28 09:05:54 EDT
Have you tried booting with "acpi=off" or "acpi=noirq" on the kernel command 
line?  Please do so and post the results here...thanks! 
Comment 3 Massimo Nicolini 2005-11-01 05:53:59 EST
Hi John, thanks for your help.

I've tried using acpi=noirq obtaining always the same situation, when i try to
ping i often obtain in /var/log Messages this:

Nov  1 15:20:04 localhost kernel: NETDEV WATCHDOG: eth0: transmit timed out
Nov  1 15:20:04 localhost kernel: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1

Even shutting down ifplugd.

When i try acpi=off , my network work perfectly with 2.6.13-1.1532_FC4 kernel,
but i cannot see battery status ( and other useful info ) about my notebook.
How can i enable this features having net card working too?

if useful , when my kernel boot, i see this lines ( with acpi=off):

Nov  1 15:24:25 localhost kernel: klogd 1.4.1, log source = /proc/kmsg started.
Nov  1 15:24:25 localhost kernel: Linux version 2.6.13-1.1532_FC4
(bhcompile@tweety.build.redhat.com) (gcc version 4.0.1 20050727 (Red Hat
4.0.1-5)) #1 Thu Oct 20 01:30:08 EDT 2005
Nov  1 15:24:25 localhost kernel: BIOS-provided physical RAM map:
Nov  1 15:24:25 localhost kernel:  BIOS-e820: 0000000000000000 -
000000000009f800 (usable)
Nov  1 15:24:25 localhost kernel:  BIOS-e820: 000000000009f800 -
00000000000a0000 (reserved)
Nov  1 15:24:25 localhost kernel:  BIOS-e820: 00000000000d0000 -
0000000000100000 (reserved)
Nov  1 15:24:25 localhost kernel:  BIOS-e820: 0000000000100000 -
000000003fef0000 (usable)
Nov  1 15:24:25 localhost kernel:  BIOS-e820: 000000003fef0000 -
000000003feff000 (ACPI data)
Nov  1 15:24:25 localhost kernel:  BIOS-e820: 000000003feff000 -
000000003ff00000 (ACPI NVS)
Nov  1 15:24:25 localhost kernel:  BIOS-e820: 000000003ff00000 -
0000000040000000 (reserved)
Nov  1 15:24:25 localhost kernel:  BIOS-e820: 00000000e0000000 -
00000000f0000000 (reserved)
Nov  1 15:24:25 localhost kernel: 126MB HIGHMEM available.
Nov  1 15:24:25 localhost kernel: 896MB LOWMEM available.
Nov  1 15:24:25 localhost kernel: Using x86 segment limits to approximate NX
protection
Nov  1 15:24:25 localhost kernel: DMI present.
Nov  1 15:24:25 localhost kernel: Allocating PCI resources starting at 40000000
(gap: 40000000:a0000000)
Nov  1 15:24:25 localhost kernel: Built 1 zonelists
Nov  1 15:24:25 localhost kernel: Kernel command line: ro root=LABEL=/ rhgb
quiet acpi=off
Nov  1 15:24:25 localhost kernel: Initializing CPU#0
Nov  1 15:24:25 localhost kernel: CPU 0 irqstacks, hard=c04e7000 soft=c04e6000
Nov  1 15:24:25 localhost kernel: PID hash table entries: 4096 (order: 12, 65536
bytes)
Nov  1 15:24:25 localhost kernel: Detected 2194.144 MHz processor.
Nov  1 15:24:25 localhost kernel: Using tsc for high-res timesource
Nov  1 15:24:25 localhost kernel: Console: colour VGA+ 80x25
Nov  1 15:24:25 localhost kernel: Dentry cache hash table entries: 131072
(order: 7, 524288 bytes)
Nov  1 15:24:25 localhost kernel: Inode-cache hash table entries: 65536 (order:
6, 262144 bytes)
Nov  1 15:24:25 localhost kernel: Memory: 1032044k/1047488k available (3085k
kernel code, 14504k reserved, 704k data, 176k init, 129984k highmem)
Nov  1 15:24:25 localhost kernel: Checking if this processor honours the WP bit
even in supervisor mode... Ok.
Nov  1 15:24:25 localhost kernel: Calibrating delay using timer specific
routine.. 4396.08 BogoMIPS (lpj=8792173)
Nov  1 15:24:25 localhost kernel: Security Framework v1.0.0 initialized
Nov  1 15:24:25 localhost kernel: SELinux:  Initializing.
Nov  1 15:24:25 localhost kernel: SELinux:  Starting in permissive mode
Nov  1 15:24:25 localhost kernel: selinux_register_security:  Registering
secondary module capability
Nov  1 15:24:25 localhost kernel: Capability LSM initialized as secondary
Nov  1 15:24:25 localhost kernel: Mount-cache hash table entries: 512
Nov  1 15:24:25 localhost kernel: CPU: L1 I Cache: 64K (64 bytes/line), D cache
64K (64 bytes/line)
Nov  1 15:24:25 localhost kernel: CPU: L2 Cache: 512K (64 bytes/line)
Nov  1 15:24:25 localhost kernel: Intel machine check architecture supported.
Nov  1 15:24:25 localhost kernel: Intel machine check reporting enabled on CPU#0.
Nov  1 15:24:25 localhost kernel: mtrr: v2.0 (20020519)
Nov  1 15:24:25 localhost kernel: CPU: AMD Athlon(tm) 64 Processor 3500+ stepping 00
Nov  1 15:24:25 localhost kernel: Enabling fast FPU save and restore... done.
Nov  1 15:24:25 localhost kernel: Enabling unmasked SIMD FPU exception
support... done.
Nov  1 15:24:25 localhost kernel: Checking 'hlt' instruction... OK.
Nov  1 15:24:25 localhost kernel: checking if image is initramfs... it is
Nov  1 15:24:25 localhost kernel: Freeing initrd memory: 1095k freed
Nov  1 15:24:25 localhost kernel: NET: Registered protocol family 16
Nov  1 15:24:25 localhost kernel: PCI: PCI BIOS revision 2.10 entry at 0xfd84c,
last bus=4
Nov  1 15:24:25 localhost kernel: PCI: Using configuration type 1
Nov  1 15:24:25 localhost kernel: ACPI: Subsystem revision 20050408
Nov  1 15:24:26 localhost kernel: ACPI: Interpreter disabled.
Nov  1 15:24:26 localhost kernel: Linux Plug and Play Support v0.97 (c) Adam Belay
Nov  1 15:24:26 localhost kernel: pnp: PnP ACPI: disabled
Nov  1 15:24:26 localhost kernel: usbcore: registered new driver usbfs
Nov  1 15:24:26 localhost kernel: usbcore: registered new driver hub
Nov  1 15:24:26 localhost kernel: PCI: Probing PCI hardware
Nov  1 15:24:26 localhost kernel: PCI: Probing PCI hardware (bus 00)
Nov  1 15:24:26 localhost kernel: PCI: Ignoring BAR0-3 of IDE controller
0000:00:14.1
Nov  1 15:24:26 localhost kernel: PCI: Transparent bridge - 0000:00:14.4
Nov  1 15:24:26 localhost kernel: PCI: Cannot allocate resource region 7 of
bridge 0000:00:04.0
Nov  1 15:24:26 localhost kernel: PCI: Cannot allocate resource region 8 of
bridge 0000:00:04.0
Nov  1 15:24:26 localhost kernel: PCI: Bridge: 0000:00:01.0
Nov  1 15:24:26 localhost kernel:   IO window: 9000-9fff
Nov  1 15:24:26 localhost kernel:   MEM window: b0100000-b01fffff
Nov  1 15:24:26 localhost kernel:   PREFETCH window: c0000000-cfffffff
Nov  1 15:24:26 localhost kernel: PCI: Bridge: 0000:00:04.0
Nov  1 15:24:26 localhost kernel:   IO window: disabled.
Nov  1 15:24:26 localhost kernel:   MEM window: disabled.
Nov  1 15:24:26 localhost kernel:   PREFETCH window: disabled.
Nov  1 15:24:26 localhost kernel: PCI: Bus 4, cardbus bridge: 0000:03:04.0
Nov  1 15:24:26 localhost kernel:   IO window: 00001000-00001fff
Nov  1 15:24:26 localhost kernel:   IO window: 00002000-00002fff
Nov  1 15:24:26 localhost kernel:   PREFETCH window: 40000000-41ffffff
Nov  1 15:24:26 localhost kernel:   MEM window: 42000000-43ffffff
Nov  1 15:24:26 localhost kernel: PCI: Bridge: 0000:00:14.4
Nov  1 15:24:26 localhost kernel:   IO window: a000-afff
Nov  1 15:24:26 localhost kernel:   MEM window: b0200000-b02fffff
Nov  1 15:24:26 localhost kernel:   PREFETCH window: 40000000-41ffffff
Nov  1 15:24:26 localhost kernel: PCI: Device 0000:00:04.0 not available because
of resource collisions
Nov  1 15:24:26 localhost kernel: apm: BIOS not found.
Nov  1 15:24:26 localhost kernel: audit: initializing netlink socket (disabled)
Nov  1 15:24:26 localhost kernel: audit(1130858619.948:1): initialized
Nov  1 15:24:26 localhost kernel: highmem bounce pool size: 64 pages
Nov  1 15:24:26 localhost kernel: Total HugeTLB memory allocated, 0
Nov  1 15:24:26 localhost kernel: VFS: Disk quotas dquot_6.5.1
Nov  1 15:24:26 localhost kernel: Dquot-cache hash table entries: 1024 (order 0,
4096 bytes)
Nov  1 15:24:26 localhost kernel: SELinux:  Registering netfilter hooks
Nov  1 15:24:26 localhost kernel: Initializing Cryptographic API
Nov  1 15:24:26 localhost kernel: ksign: Installing public key data
Nov  1 15:24:26 localhost kernel: Loading keyring
Nov  1 15:24:26 localhost kernel: - Added public key EEDDDBBBC3364C64
Nov  1 15:24:26 localhost kernel: - User ID: Red Hat, Inc. (Kernel Module GPG key)
Nov  1 15:24:26 localhost kernel: pci_hotplug: PCI Hot Plug PCI Core version: 0.5
Nov  1 15:24:26 localhost kernel: PCI: Device 0000:00:04.0 not available because
of resource collisions
Nov  1 15:24:26 localhost kernel: isapnp: Scanning for PnP cards...
Nov  1 15:24:26 localhost kernel: isapnp: No Plug & Play device found
Nov  1 15:24:26 localhost kernel: Real Time Clock Driver v1.12
Nov  1 15:24:26 localhost kernel: Linux agpgart interface v0.101 (c) Dave Jones
Nov  1 15:24:26 localhost kernel: PNP: No PS/2 controller found. Probing ports
directly
Nov  1 15:24:26 localhost kernel: i8042.c: MUX probe failed. USB legacy enabled
in BIOS?
Nov  1 15:24:26 localhost kernel: serio: i8042 AUX port at 0x60,0x64 irq 12
Nov  1 15:24:26 localhost kernel: serio: i8042 KBD port at 0x60,0x64 irq 1
Nov  1 15:24:26 localhost kernel: Serial: 8250/16550 driver $Revision: 1.90 $ 32
ports, IRQ sharing enabled
Nov  1 15:24:26 localhost kernel: io scheduler noop registered
Nov  1 15:24:26 localhost kernel: io scheduler anticipatory registered
Nov  1 15:24:26 localhost kernel: io scheduler deadline registered
Nov  1 15:24:26 localhost kernel: io scheduler cfq registered
Nov  1 15:24:26 localhost kernel: RAMDISK driver initialized: 16 RAM disks of
16384K size 1024 blocksize
Nov  1 15:24:26 localhost kernel: Uniform Multi-Platform E-IDE driver Revision:
7.00alpha2
Nov  1 15:24:26 localhost kernel: ide: Assuming 33MHz system bus speed for PIO
modes; override with idebus=xx
Nov  1 15:24:26 localhost kernel: ATIIXP: IDE controller at PCI slot 0000:00:14.1
Nov  1 15:24:26 localhost kernel: ATIIXP: chipset revision 0
Nov  1 15:24:26 localhost kernel: ATIIXP: not 100% native mode: will probe irqs
later
Nov  1 15:24:27 localhost kernel:     ide0: BM-DMA at 0x8410-0x8417, BIOS
settings: hda:DMA, hdb:pio
Nov  1 15:24:27 localhost kernel:     ide1: BM-DMA at 0x8418-0x841f, BIOS
settings: hdc:DMA, hdd:pio
Nov  1 15:24:27 localhost kernel: hda: ST9100822A, ATA DISK drive
Nov  1 15:24:27 localhost kernel: ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Nov  1 15:24:27 localhost kernel: hdc: PIONEER DVDRW DVR-K15, ATAPI CD/DVD-ROM drive
Nov  1 15:24:27 localhost kernel: ide1 at 0x170-0x177,0x376 on irq 15
Nov  1 15:24:27 localhost kernel: hda: max request size: 1024KiB
Nov  1 15:24:27 localhost kernel: hda: 195371568 sectors (100030 MB) w/8192KiB
Cache, CHS=16383/255/63, UDMA(100)
Nov  1 15:24:27 localhost kernel: hda: cache flushes supported
Nov  1 15:24:27 localhost kernel:  hda: hda1 hda2 hda3 hda4
Nov  1 15:24:27 localhost kernel: hdc: ATAPI 24X DVD-ROM DVD-R CD-R/RW drive,
2000kB Cache, DMA
Nov  1 15:24:27 localhost kernel: Uniform CD-ROM driver Revision: 3.20
Nov  1 15:24:27 localhost kernel: ide-floppy driver 0.99.newide
Nov  1 15:24:27 localhost kernel: usbcore: registered new driver hiddev
Nov  1 15:24:27 localhost kernel: usbcore: registered new driver usbhid
Nov  1 15:24:27 localhost kernel: drivers/usb/input/hid-core.c: v2.01:USB HID
core driver
Nov  1 15:24:27 localhost kernel: mice: PS/2 mouse device common for all mice
Nov  1 15:24:27 localhost kernel: md: md driver 0.90.2 MAX_MD_DEVS=256,
MD_SB_DISKS=27
Nov  1 15:24:27 localhost kernel: md: bitmap version 3.38
Nov  1 15:24:27 localhost kernel: NET: Registered protocol family 2
Nov  1 15:24:27 localhost kernel: input: AT Translated Set 2 keyboard on
isa0060/serio0
Nov  1 15:24:27 localhost kernel: IP route cache hash table entries: 32768
(order: 5, 131072 bytes)
Nov  1 15:24:27 localhost kernel: TCP established hash table entries: 131072
(order: 8, 1048576 bytes)
Nov  1 15:24:27 localhost kernel: TCP bind hash table entries: 65536 (order: 8,
1835008 bytes)
Nov  1 15:24:27 localhost kernel: TCP: Hash tables configured (established
131072 bind 65536)
Nov  1 15:24:27 localhost kernel: TCP reno registered
Nov  1 15:24:27 localhost kernel: TCP bic registered
Nov  1 15:24:27 localhost kernel: Initializing IPsec netlink socket
Nov  1 15:24:27 localhost kernel: NET: Registered protocol family 1
Nov  1 15:24:27 localhost kernel: NET: Registered protocol family 17
Nov  1 15:24:27 localhost kernel: Using IPI Shortcut mode
Nov  1 15:24:27 localhost kernel: Freeing unused kernel memory: 176k freed
Nov  1 15:24:27 localhost kernel: kjournald starting.  Commit interval 5 seconds
Nov  1 15:24:27 localhost kernel: EXT3-fs: mounted filesystem with ordered data
mode.
Nov  1 15:24:27 localhost kernel: input: ImPS/2 Generic Wheel Mouse on
isa0060/serio1
Nov  1 15:24:27 localhost kernel: SELinux:  Disabled at runtime.
Nov  1 15:24:27 localhost kernel: SELinux:  Unregistering netfilter hooks
Nov  1 15:24:27 localhost kernel: floppy0: no floppy controllers found
Nov  1 15:24:27 localhost kernel: 8139too Fast Ethernet driver 0.9.27
Nov  1 15:24:27 localhost kernel: eth0: RealTek RTL8139 at 0xa000,
00:0f:b0:75:87:82, IRQ 10
Nov  1 15:24:27 localhost kernel: atiixp: no codec available
Nov  1 15:24:27 localhost kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID
fail=0x1001
Nov  1 15:24:27 localhost kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID
fail=0x1001
Nov  1 15:24:27 localhost kernel: ehci_hcd 0000:00:13.2: EHCI Host Controller
Nov  1 15:24:27 localhost kernel: ehci_hcd 0000:00:13.2: new USB bus registered,
assigned bus number 1
Nov  1 15:24:27 localhost kernel: ehci_hcd 0000:00:13.2: irq 11, io mem 0xb0002000
Nov  1 15:24:27 localhost kernel: ehci_hcd 0000:00:13.2: USB 2.0 initialized,
EHCI 1.00, driver 10 Dec 2004
Nov  1 15:24:27 localhost kernel: hub 1-0:1.0: USB hub found
Nov  1 15:24:27 localhost kernel: hub 1-0:1.0: 8 ports detected
Nov  1 15:24:27 localhost kernel: ohci_hcd 0000:00:13.0: OHCI Host Controller
Nov  1 15:24:27 localhost kernel: ohci_hcd 0000:00:13.0: new USB bus registered,
assigned bus number 2
Nov  1 15:24:27 localhost kernel: ohci_hcd 0000:00:13.0: irq 11, io mem 0xb0000000
Nov  1 15:24:27 localhost kernel: hub 2-0:1.0: USB hub found
Nov  1 15:24:27 localhost kernel: hub 2-0:1.0: 4 ports detected
Nov  1 15:24:27 localhost kernel: ohci_hcd 0000:00:13.1: OHCI Host Controller
Nov  1 15:24:27 localhost kernel: usb 2-1: new low speed USB device using
ohci_hcd and address 2
Nov  1 15:24:28 localhost kernel: ohci_hcd 0000:00:13.1: new USB bus registered,
assigned bus number 3
Nov  1 15:24:28 localhost kernel: ohci_hcd 0000:00:13.1: irq 11, io mem 0xb0001000
Nov  1 15:24:28 localhost kernel: hub 3-0:1.0: USB hub found
Nov  1 15:24:28 localhost kernel: hub 3-0:1.0: 4 ports detected
Nov  1 15:24:28 localhost kernel: input: USB HID v1.00 Mouse [1241:1122] on
usb-0000:00:13.0-1
Nov  1 15:24:28 localhost kernel: Yenta: CardBus bridge found at 0000:03:04.0
[103c:3085]
Nov  1 15:24:28 localhost kernel: Yenta: ISA IRQ mask 0x02f8, PCI irq 10
Nov  1 15:24:28 localhost kernel: Socket status: 30000006
Nov  1 15:24:28 localhost kernel: pcmcia: parent PCI bridge I/O window: 0xa000 -
0xafff
Nov  1 15:24:28 localhost kernel: cs: IO port probe 0xa000-0xafff: clean.
Nov  1 15:24:28 localhost kernel: pcmcia: parent PCI bridge Memory window:
0xb0200000 - 0xb02fffff
Nov  1 15:24:28 localhost kernel: pcmcia: parent PCI bridge Memory window:
0x40000000 - 0x41ffffff
Nov  1 15:24:28 localhost kernel: ohci1394: $Rev: 1299 $ Ben Collins
<bcollins@debian.org>
Nov  1 15:24:28 localhost kernel: ohci1394: fw-host0: OHCI-1394 1.1 (PCI):
IRQ=[10]  MMIO=[b0208000-b02087ff]  Max Packet=[2048]
Nov  1 15:24:28 localhost kernel: NET: Registered protocol family 10
Nov  1 15:24:28 localhost kernel: Disabled Privacy Extensions on device c04756a0(lo)
Nov  1 15:24:28 localhost kernel: IPv6 over IPv4 tunneling driver
Nov  1 15:24:28 localhost kernel: mtrr: no more MTRRs available
Nov  1 15:24:28 localhost kernel: md: Autodetecting RAID arrays.
Nov  1 15:24:28 localhost kernel: md: autorun ...
Nov  1 15:24:28 localhost kernel: md: ... autorun DONE.
Nov  1 15:24:28 localhost kernel: device-mapper: 4.4.0-ioctl (2005-01-12)
initialised: dm-devel@redhat.com
Nov  1 15:24:28 localhost kernel: cdrom: open failed.
Nov  1 15:24:28 localhost kernel: cdrom: open failed.
Nov  1 15:24:28 localhost kernel: EXT3 FS on hda3, internal journal
Nov  1 15:24:28 localhost kernel: Adding 2096472k swap on /dev/hda4. 
Priority:-1 extents:1
Nov  1 15:24:28 localhost kernel: cs: IO port probe 0xc00-0xcff: excluding
0xc00-0xc07 0xc10-0xc17 0xc50-0xc57 0xc68-0xc6f 0xcd0-0xcdf
Nov  1 15:24:28 localhost kernel: cs: IO port probe 0x800-0x8ff: excluding
0x878-0x87f
Nov  1 15:24:28 localhost kernel: cs: IO port probe 0x100-0x4ff: excluding
0x408-0x40f 0x4d0-0x4d7
Nov  1 15:24:28 localhost kernel: cs: IO port probe 0xa00-0xaff: clean.
Nov  1 15:24:28 localhost kernel: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
Nov  1 15:24:30 localhost kernel: vmmon: module license 'unspecified' taints kernel.
Nov  1 15:24:30 localhost kernel: bridge-eth0: already up
Nov  1 15:24:31 localhost kernel: Bluetooth: Core ver 2.7
Nov  1 15:24:31 localhost kernel: NET: Registered protocol family 31
Nov  1 15:24:31 localhost kernel: Bluetooth: HCI device and connection manager
initialized
Nov  1 15:24:31 localhost kernel: Bluetooth: HCI socket layer initialized
Nov  1 15:24:31 localhost kernel: Bluetooth: L2CAP ver 2.7
Nov  1 15:24:31 localhost kernel: Bluetooth: L2CAP socket layer initialized
Nov  1 15:24:31 localhost kernel: Bluetooth: RFCOMM ver 1.5
Nov  1 15:24:32 localhost kernel: Bluetooth: RFCOMM socket layer initialized
Nov  1 15:24:32 localhost kernel: Bluetooth: RFCOMM TTY layer initialized
Nov  1 15:24:32 localhost kernel: i2c /dev entries driver
Nov  1 15:24:35 localhost kernel: NET: Registered protocol family 23
Nov  1 15:24:35 localhost kernel: IrCOMM protocol (Dag Brattli)
Nov  1 15:24:35 localhost kernel: CSLIP: code copyright 1989 Regents of the
University of California
Nov  1 15:24:35 localhost kernel: PPP generic driver version 2.4.2
Nov  1 15:24:38 localhost kernel: lp: driver loaded but no devices found
Nov  1 15:24:53 localhost kernel: mtrr: no more MTRRs available
Nov  1 15:25:11 localhost kernel: Non-volatile memory driver v1.2

I've some doubts about lines:
Nov  1 15:24:26 localhost kernel: PCI: Transparent bridge - 0000:00:14.4
Nov  1 15:24:26 localhost kernel: PCI: Cannot allocate resource region 7 of
bridge 0000:00:04.0
Nov  1 15:24:26 localhost kernel: PCI: Cannot allocate resource region 8 of
bridge 0000:00:04.0
Nov  1 15:24:26 localhost kernel: PCI: Bridge: 0000:00:01.0
Nov  1 15:24:26 localhost kernel:   IO window: 9000-9fff
Nov  1 15:24:26 localhost kernel:   MEM window: b0100000-b01fffff
Nov  1 15:24:26 localhost kernel:   PREFETCH window: c0000000-cfffffff
Nov  1 15:24:26 localhost kernel: PCI: Bridge: 0000:00:04.0
Nov  1 15:24:26 localhost kernel:   IO window: disabled.
Nov  1 15:24:26 localhost kernel:   MEM window: disabled.
Nov  1 15:24:26 localhost kernel:   PREFETCH window: disabled.
Nov  1 15:24:26 localhost kernel: PCI: Bus 4, cardbus bridge: 0000:03:04.0
Nov  1 15:24:26 localhost kernel:   IO window: 00001000-00001fff
Nov  1 15:24:26 localhost kernel:   IO window: 00002000-00002fff
Nov  1 15:24:26 localhost kernel:   PREFETCH window: 40000000-41ffffff
Nov  1 15:24:26 localhost kernel:   MEM window: 42000000-43ffffff
Nov  1 15:24:26 localhost kernel: PCI: Bridge: 0000:00:14.4
Nov  1 15:24:26 localhost kernel:   IO window: a000-afff
Nov  1 15:24:26 localhost kernel:   MEM window: b0200000-b02fffff
Nov  1 15:24:26 localhost kernel:   PREFETCH window: 40000000-41ffffff
Nov  1 15:24:26 localhost kernel: PCI: Device 0000:00:04.0 not available because
of resource collisions

My lspci -v is:
00:00.0 Host bridge: ATI Technologies Inc: Unknown device 5950
        Subsystem: Hewlett-Packard Company: Unknown device 3085
        Flags: bus master, 66Mhz, medium devsel, latency 64

00:01.0 PCI bridge: ATI Technologies Inc: Unknown device 5a3f (prog-if 00
[Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 64
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
        I/O behind bridge: 00009000-00009fff
        Memory behind bridge: b0100000-b01fffff
        Prefetchable memory behind bridge: 00000000c0000000-00000000cff00000
        Capabilities: [44] HyperTransport: MSI Mapping
        Capabilities: [b0] #0d [0000]

00:04.0 PCI bridge: ATI Technologies Inc: Unknown device 5a36 (prog-if 00
[Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
        Capabilities: [50] Power Management version 3
        Capabilities: [58] Express Root Port (Slot-) IRQ 0
        Capabilities: [80] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-
        Capabilities: [b0] #0d [0000]
        Capabilities: [b8] HyperTransport: MSI Mapping

00:13.0 USB Controller: ATI Technologies Inc: Unknown device 4374 (prog-if 10
[OHCI])
        Subsystem: ATI Technologies Inc: Unknown device 4374
        Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
        Memory at b0000000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [d0] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-

00:13.1 USB Controller: ATI Technologies Inc: Unknown device 4375 (prog-if 10
[OHCI])
        Subsystem: ATI Technologies Inc: Unknown device 4375
        Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
        Memory at b0001000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [d0] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-

00:13.2 USB Controller: ATI Technologies Inc: Unknown device 4373 (prog-if 20
[EHCI])
        Subsystem: ATI Technologies Inc: Unknown device 4373
        Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
        Memory at b0002000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [dc] Power Management version 2
        Capabilities: [d0] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-

00:14.0 SMBus: ATI Technologies Inc ATI SMBus (rev 10)
        Subsystem: Hewlett-Packard Company: Unknown device 3085
        Flags: 66Mhz, medium devsel
        I/O ports at 8400 [size=16]
        Memory at b0003000 (32-bit, non-prefetchable) [size=1K]
        Capabilities: [b0] HyperTransport: MSI Mapping

00:14.1 IDE interface: ATI Technologies Inc Standard Dual Channel PCI IDE
Controller ATI (prog-if 8a [Master SecP PriP])
        Subsystem: Hewlett-Packard Company: Unknown device 3085
        Flags: bus master, 66Mhz, medium devsel, latency 0
        I/O ports at <ignored>
        I/O ports at <ignored>
        I/O ports at <ignored>
        I/O ports at <ignored>
        I/O ports at 8410 [size=16]
        Capabilities: [70] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-

00:14.3 ISA bridge: ATI Technologies Inc: Unknown device 4377
        Flags: bus master, 66Mhz, medium devsel, latency 0

00:14.4 PCI bridge: ATI Technologies Inc: Unknown device 4371 (prog-if 01
[Subtractive decode])
        Flags: bus master, 66Mhz, medium devsel, latency 64
        Bus: primary=00, secondary=03, subordinate=07, sec-latency=64
        I/O behind bridge: 0000a000-0000afff
        Memory behind bridge: b0200000-b02fffff
        Prefetchable memory behind bridge: 40000000-41ffffff

00:14.5 Multimedia audio controller: ATI Technologies Inc: Unknown device 4370
(rev 01)
        Subsystem: Hewlett-Packard Company: Unknown device 3085
        Flags: bus master, 66Mhz, slow devsel, latency 64, IRQ 10
        Memory at b0003400 (32-bit, non-prefetchable) [size=256]
        Capabilities: [40] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-

00:14.6 Modem: ATI Technologies Inc: Unknown device 4378 (rev 01) (prog-if 00
[Generic])
        Subsystem: Hewlett-Packard Company: Unknown device 3085
        Flags: 66Mhz, slow devsel, IRQ 10
        Memory at b0003800 (32-bit, non-prefetchable) [size=256]
        Capabilities: [40] Message Signalled Interrupts: 64bit- Queue=0/0 Enable-

00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
        Flags: fast devsel
        Capabilities: [80] HyperTransport: Host or Secondary Interface

00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
        Flags: fast devsel

00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
        Flags: fast devsel

00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
        Flags: fast devsel

01:05.0 VGA compatible controller: ATI Technologies Inc: Unknown device 5955
(prog-if 00 [VGA])
        Subsystem: Hewlett-Packard Company: Unknown device 3085
        Flags: bus master, fast Back2Back, 66Mhz, medium devsel, latency 255, IRQ 10
        Memory at c0000000 (32-bit, prefetchable) [size=256M]
        I/O ports at 9000 [size=256]
        Memory at b0100000 (32-bit, non-prefetchable) [size=64K]
        [virtual] Expansion ROM at b0120000 [disabled] [size=128K]
        Capabilities: [50] Power Management version 2

03:00.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000
Controller (PHY/Link) (prog-if 10 [OHCI])
        Subsystem: Hewlett-Packard Company: Unknown device 3085
        Flags: bus master, medium devsel, latency 64, IRQ 10
        Memory at b0208000 (32-bit, non-prefetchable) [size=2K]
        Memory at b0200000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [44] Power Management version 2

03:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN
Controller (rev 03)
        Subsystem: Hewlett-Packard Company: Unknown device 12fa
        Flags: bus master, fast devsel, latency 64, IRQ 10
        Memory at b0204000 (32-bit, non-prefetchable) [size=8K]

03:04.0 CardBus bridge: Texas Instruments Texas Instruments PCIxx21/x515 Cardbus
Controller
        Subsystem: Hewlett-Packard Company: Unknown device 3085
        Flags: bus master, medium devsel, latency 168, IRQ 10
        Memory at b0209000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=03, secondary=04, subordinate=07, sec-latency=176
        Memory window 0: 40000000-41fff000 (prefetchable)
        Memory window 1: 42000000-43fff000
        I/O window 0: 00001000-00001fff
        I/O window 1: 00002000-00002fff
        16-bit legacy interface ports at 0001

03:04.3 Unknown mass storage controller: Texas Instruments Texas Instruments
PCIxx21 Integrated FlashMedia Controller
        Subsystem: Hewlett-Packard Company: Unknown device 3085
        Flags: bus master, medium devsel, latency 64, IRQ 10
        Memory at b0206000 (32-bit, non-prefetchable) [size=8K]
        Capabilities: [44] Power Management version 2

03:04.4 Class 0805: Texas Instruments Texas Instruments PCI6411, PCI6421,
PCI6611, PCI6621, PCI7411, PCI7421, PCI7611, PCI7621 Secure Digital (SD) 
        Subsystem: Hewlett-Packard Company: Unknown device 3085
        Flags: bus master, medium devsel, latency 64, IRQ 10
        Memory at b020a000 (32-bit, non-prefetchable) [size=256]
        Memory at b0208c00 (32-bit, non-prefetchable) [size=256]
        Memory at b0208800 (32-bit, non-prefetchable) [size=256]
        Capabilities: [80] Power Management version 2

03:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
        Subsystem: Hewlett-Packard Company: Unknown device 3085
        Flags: bus master, medium devsel, latency 64, IRQ 10
        I/O ports at a000 [size=256]
        Memory at b020a400 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2

Note: Ati, does't works and when kernel modules is loaded before startx i can
achieve that module is loaded , i can see x starting but i can't see X in the
middle of the screen and notebook freeze ( i think a kernel panic occours )
Comment 4 Massimo Nicolini 2005-11-01 05:57:19 EST
When i say ATI doesn't work i mean 3D, 2D works perfectly ( is a xorg module)
Thanks
Bye Massimo
Comment 5 John W. Linville 2005-11-01 13:56:36 EST
With acpi=off, you won't be able to monitor your battery, etc.  You might try 
using "noapic" instead -- no promises. 
 
Unfortunately, this indicates a problem with the ACPI code in your BIOS.  
There is essentially nothing I can do about this.  Your best bet is to seek a 
BIOS update from your vendor.  If all else fails, you might check-out the page 
here: 
 
   http://people.redhat.com/linville/kernels/dsdt/ 
 
Again, there is nothing I can do officially to fix this problem.  I'm sorry. 
Comment 6 Massimo Nicolini 2005-11-02 05:07:25 EST
Hi John, noapic doesn't resolve this problem.
I found a bios update, but i saw only fixes for Hibernation mode.
I've downloaded kernels at http://people.redhat.com/linville/kernels/dsdt/.
Tonight i'll try them and i'll report results.
Bye and Thanks
I apologize for my English.
Massimo
Comment 7 Massimo Nicolini 2005-11-02 05:43:25 EST
Hi John, noapic doesn't resolve this problem.
I found a bios update, but i saw only fixes for Hibernation mode.
I've downloaded kernels at http://people.redhat.com/linville/kernels/dsdt/.
Tonight i'll try them and i'll report results.
Bye and Thanks
I apologize for my English.
Massimo
Comment 8 Massimo Nicolini 2005-11-02 06:32:43 EST
Hi John, i've tried kernels you suggested me,i've downloaded a i686 kernel, but
the problem persist.
With this kernel i loss 33% of packets and i case of ping i can achieve  times
between 16ms to 1200 ms, so connection often hangs.
Bye
Massimo

Note You need to log in before you can comment on or make changes to this bug.