This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 171888 - totem can't start
totem can't start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-27 10:39 EDT by sangu
Modified: 2013-03-13 00:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-28 14:52:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description sangu 2005-10-27 10:39:15 EDT
$totem
(totem:22045): libglade-WARNING **: could not find widget creation function

(totem:22045): libglade-WARNING **: could not find widget creation function

(totem:22045): libglade-WARNING **: could not find widget creation function

(totem:22045): GLib-GObject-WARNING **: gsignal.c:1716: signal `value-changed'
is invalid for instance `0x9e893c0'

(totem:22045): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to
`BaconVolumeButton'

(totem:22045): Gtk-CRITICAL **: gtk_range_set_value: assertion `GTK_IS_RANGE
(range)' failed

(totem:22045): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to
`BaconVolumeButton'

(totem:22045): Gtk-CRITICAL **: gtk_range_set_value: assertion `GTK_IS_RANGE
(range)' failed

(totem:22045): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to
`TotemStatusbar'

** (totem:22045): CRITICAL **: totem_statusbar_set_time_and_length: assertion
`TOTEM_IS_STATUSBAR (statusbar)' failed

(totem:22045): GLib-GObject-WARNING **: invalid cast from `GtkLabel' to
`TotemStatusbar'

Description of problem:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208404304 (LWP 22041)]
0x0080068d in g_type_check_instance_cast () from /usr/lib/libgobject-2.0.so.0
(gdb) bt
#0  0x0080068d in g_type_check_instance_cast ()
   from /usr/lib/libgobject-2.0.so.0
#1  0x0806c0d5 in totem_statusbar_set_text (statusbar=0x8e42e70,
    label=0xb7cbbf85 "\uffff\uffff\210\ucda4") at totem-statusbar.c:204
#2  0x080598a2 in update_mrl_label (totem=0x8db3900, name=0x0) at totem.c:651
#3  0x0805c9f2 in totem_action_set_mrl_with_warning (totem=0x8db3900, mrl=0x0,
    warn=1) at totem.c:723
#4  0x0805ca1e in totem_action_set_mrl (totem=0x8db3900, mrl=0x0)
    at totem.c:796
#5  0x08060bc6 in main (argc=0, argv=0xbfbb9428) at totem.c:3494
#6  0x06b7350f in __libc_start_main () from /lib/libc.so.6
#7  0x08054df1 in _start ()


Version-Release number of selected component (if applicable):
1.2.0-1

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lars G 2005-10-27 20:50:08 EDT
same behavior here
Comment 2 John (J5) Palmieri 2005-10-28 13:43:12 EDT
Fixing right now.  hould be in the next compose
Comment 3 John (J5) Palmieri 2005-10-28 14:52:46 EDT
1.2.0-2 is built and works for me.  If it still segfaults reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.