Bug 171894 - Buttons in Web UI are not translatable
Buttons in Web UI are not translatable
Status: CLOSED DUPLICATE of bug 210695
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Usability (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Máirín Duffy
Beth Nackashi
: 150679 210702 (view as bug list)
Depends On:
Blocks: 166615
  Show dependency treegraph
Reported: 2005-10-27 11:48 EDT by Máirín Duffy
Modified: 2007-10-23 22:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-02-13 18:03:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
The Buttons (17.00 KB, image/png)
2005-10-27 11:48 EDT, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2005-10-27 11:48:43 EDT
For 410 we will be translating the RHN Web UI into many languages. Currently, we
have many image buttons in the interface that have text embedded into them. As
they are, we would have to send the button text to the translation team and
create an image for each button per language manually.

A better solution is to get away from using image-based buttons and instead use
CSS to style the buttons, so the button text is in plain text that the
translation team can translate along with all of the other text. 

Attached is an image of the current button styles as compared to a few options
we have for CSS styling:

D: The current image-based buttons.
A: A css style that matches our current buttons most closely, but has
complicated CSS styling.
B & C: A css style that matches our current buttons somewhat closely, with a
very simple CSS style.
E: The button style WWW uses for www.redhat.com buttons

My vote's for A or B&C (depending on whether or not A causes cross-browser
issues which is pretty likely)
Comment 1 Máirín Duffy 2005-10-27 11:48:43 EDT
Created attachment 120470 [details]
The Buttons
Comment 3 Jesus M. Rodriguez 2005-10-29 21:55:01 EDT
Let's do a UI spec, and start a dialog on this on rhn-java-list.  My vote's are
as follows:

B & C

I like the flatter look and feel.
Comment 4 Máirín Duffy 2006-10-13 16:57:18 EDT
*** Bug 210702 has been marked as a duplicate of this bug. ***
Comment 5 Ken Ganong 2006-10-30 12:15:20 EST
*** Bug 150679 has been marked as a duplicate of this bug. ***
Comment 6 Máirín Duffy 2007-02-13 18:03:30 EST

*** This bug has been marked as a duplicate of 210695 ***

Note You need to log in before you can comment on or make changes to this bug.