Bug 171918 - OpenOffice.org does not support LDAP address book
OpenOffice.org does not support LDAP address book
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-27 16:32 EDT by Anthony Messina
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.1-143.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-05 04:09:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Messina 2005-10-27 16:32:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The OpenOffice website and the installed OpenOffice help files show how to set up an LDAP address book source.  However, when using "File > Wizards > Address Data Source" and choosing "LDAP address data" from the wizard menu, OpenOffice presents you with the popup that states "The data source does not contain any tables. Do you want to set it up as an address source anyway? [Yes] [No]" and does not give you the option to enter any LDAP information.


Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.0-3.2.1

How reproducible:
Always

Steps to Reproduce:
1. Choose File > Wizards > Address Data Source
2. Choose LDAP address data
3. Hit [Next].
  

Actual Results:  OpenOffice then has a popup that states "The data source does not contain any tables. Do you want to set it up as an address source anyway? [Yes] [No]"

Expected Results:  OpenOffice should allow you to enter the LDAP connection data (server, port, base dn, etc.)

Additional info:

The LDAP Address Book function works flawlessly with the MS Windows version of OpenOffice and does not produce this error.

I marked this bug as "High" because this is an integral function of OpenOffice that did work without a hitch in OpenOffice 1.  Without this function, all LDAP integration is lost.  I have not found a workaround.
Comment 1 Caolan McNamara 2005-10-28 06:35:47 EDT
yes, I see the problem
Comment 2 Caolan McNamara 2005-10-28 06:45:01 EDT
will be fixed in next update
Comment 3 Anthony Messina 2005-10-28 12:45:44 EDT
why thank you.  i appreciate it.

Note You need to log in before you can comment on or make changes to this bug.