Bug 171927 - Keybindings for Sun Type 6 USB keyboard only work in Desktop and Sound sections
Summary: Keybindings for Sun Type 6 USB keyboard only work in Desktop and Sound sections
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: control-center   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Control Center Maintainer
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-27 20:59 UTC by Erik Volkman
Modified: 2010-06-04 21:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-04 21:40:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Erik Volkman 2005-10-27 20:59:59 UTC
Description of problem:
It appears that the extra keys on a Sun Type 6 USB keyboard only don't work for
items in the Window Management portion of the Keyboard Shortcuts. They'll
work fine for changing the volume, ejecting disks, opening Home, etc. However it
doesn't appear that those bindings are broken because other shortcuts
(<Shift><Alt><F3>) will work for the window management stuff.

Version-Release number of selected component (if applicable):

Version 2.8.0 
Release 12

Steps to Reproduce:
1. Open up Keyboard Shortcuts (Applications -> Preferences -> Keyboard Shortcuts)
2. Scroll down to the Window management section and select one of those.
3. Hit one of the side keys (Front in this case)
4. See the key code appear (0x8c)
5. Close the Shortcuts menu, try it.
6. Reopen Shortcuts, delete the binding and create a binding for Eject using the
same key.
7. Close the Shortcuts menu, hit the key, watch the drive open.
  

Additional info:

You can get it to work by assigning those keys kysysms with xmodmap such as:
xmodmap -e 'keycode 0x8c = Select' and then when you try to create the binding
it'll work as expected.

Comment 1 Erik Volkman 2005-10-27 21:00:47 UTC
Forgot to mention that this used to work in RHEL3 without problems.

Comment 2 Issue Tracker 2007-07-11 02:49:35 UTC
Internal Status set to 'Resolved'
Status set to: Closed by Client
Resolution set to: 'Closed by Client'

This event sent from IssueTracker by kr-hitron1 
 issue 124362

Comment 3 Russell Doty 2010-06-04 21:40:32 UTC
Issue tracker was closed in 2007.


Note You need to log in before you can comment on or make changes to this bug.