Bug 171956 - Unable to link Oracle 10G R2
Unable to link Oracle 10G R2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: binutils (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-28 03:25 EDT by Iustin Pop
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.15.92.0.2-18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 09:27:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Iustin Pop 2005-10-28 03:25:14 EDT
Description of problem:
Cannot link Oracle 10G R2 on x86_64. It seems to be a problem with the linker.

Version-Release number of selected component (if applicable):
binutils-2.15.92.0.2-15

How reproducible:
Install Oracle 10G R2. At link time, it fails with:
INFO: /usr/bin/gcc -o libsrvm10.so -u
Java_oracle_ops_mgmt_nativesystem_Native_getEnvironment -u
Java_oracle_ops_mgmt_nativesystem_Native_getRDBMSVersion -u
Java_oracle_ops_mgmt_nativesystem_UnixNative_startDaemon -u
Java_oracle_ops_mgmt_nativesystem_UnixNative_validateRawDevice -u
Java_oracle_ops_mgmt_nativesystem_UnixNative_getOracleGroup -u
Java_oracle_ops_mgmt_nativesystem_UnixNative_getEffectiveGroup -h
libsrvm10.so -shared /orasapp/product/10.2.0.1/srvm/lib/libsrvm10.a
-L/orasapp/product/10.2.0.1/lib/ -L/or
INFO: asapp/product/10.2.0.1/lib/ -L/orasapp/product/10.2.0.1/srvm/lib/
/orasapp/product/10.2.0.1/rdbms/lib/config.o -ldl -lm -lpthread -lnsl
-lirc -Wl,-rpath,/orasapp/product/10.2.0.1/lib -lm -ldl -lm -lpthread
-lnsl -lirc -lm -lm -L/orasapp/product/10.2.0.1/lib

INFO: gcc: unrecognized option `-h'

INFO: /
INFO: usr/bin/ld:
/orasapp/product/10.2.0.1/lib//libirc.a(fast_memcpy.o): relocation
R_X86_64_PC32 against `_memcpy_mem_ops_method' can not be used when
making a shared object; recompile with -fPIC
/usr/bin/ld: final link failed: Bad value
collect2: ld returned 1 exit status

Here, the -h unrecognized option is harmless. Even without it, it fails. From
what I've searched on the net, it seems that it is a bug in binutils, which has
been fixed in 2.15.94. I found the bug
http://sources.redhat.com/bugzilla/show_bug.cgi?id=679 which shows a similar
behaviour.

Could we please have a confirmation that this is the problem, and if so, a
patched binutils?

Thanks,
Iustin Pop
Comment 2 Per Steinar Iversen 2006-01-20 09:47:59 EST
I encountered this problems today on AS4 U2. The solution was to add the patch
from http://sources.redhat.com/ml/binutils/2005-01/msg00232.html to the binutils
src-rpm and rebuild. Oracle then installed without problems and seems to be working.
Comment 3 Iustin Pop 2006-01-20 10:08:04 EST
FYI, Oracle provides an pached (and slightly older) version of binutils, which
works as expected.

Note You need to log in before you can comment on or make changes to this bug.