Bug 17196 - NFS install problems
NFS install problems
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: installer (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-02 20:31 EDT by Chris Kloiber
Modified: 2007-04-18 12:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-22 12:35:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Kloiber 2000-09-02 20:31:29 EDT
Booting from bootnet.img (downloaded 9-2-2000) 

1) Obtaining DHCP fails to get DNS server (worked fine for 6.2 on same
network).

2) When starting anaconda you get an "exec: Permission Denied" error. Then
the machine shuts down and reboots. HTTP install works fine without
changing any permissions.
Comment 1 Michael Fulbright 2000-09-07 16:42:38 EDT
What type of install results in the permission denied error?
Comment 2 Chris Kloiber 2000-09-07 20:31:14 EDT
NFS installs get the error. FTP and HTTP seem to work fine.
Comment 3 Michael Fulbright 2000-09-29 15:11:28 EDT
It sounds like the NFS mount is failing for some reason - if you look on virtual
console 3 (hit cntl-alt-F3) do you see anything to that effect in the log
messages?
Comment 4 Need Real Name 2000-10-02 10:23:13 EDT
same problem here.  RH7 fails to do a kickstart install from NFS.
network is up and running (configured with dhcp), the log says it
could'nt mount the NFS filesystem (that's why it has no ks.cfg
file and gives up).  RH6.2 works just fine.

NFS Server is a Debian/potato box, 2.4.0-test8, knfsd.
/home/ftp is listed in /etc/exports, /home/ftp/pub/redhat is a
redhat mirror from where stuff gets installed.  The kickstart
config file is located there too.
Comment 5 Chris Kloiber 2000-10-02 10:37:21 EDT
My NFS Server is Red Hat 6.2 / Alpha and was chatting quite happily with the
machine I was installing with when it was also Red Hat 6.2.
Comment 6 Michael Fulbright 2000-10-24 12:39:01 EDT
Related to bug 16533.
Comment 7 Michael Fulbright 2000-11-13 16:34:39 EST
Passed to QA to verify against a Red Hat Linux 6.2/Alpha system.
Comment 8 Brock Organ 2000-11-14 09:45:13 EST
Chris:

> 1) Obtaining DHCP fails to get DNS server (worked fine for 6.2 on same
> network).

Immediately after choosing DHCP and advancing to the next screen, does the text
on VC-4 indicate valid DNS server IPs ...? 

(example here in test shows the information passed by dnsServers[] lines:

...
<15>Nov 14 14:41:15 loader: intf: netmask: x.x.x.x
<15>Nov 14 14:41:15 loader: intf: gateway: x.x.x.x
<15>Nov 14 14:41:15 loader: intf: dnsServers[0]: x.x.x.x
<15>Nov 14 14:41:15 loader: intf: dnsServers[1]: x.x.x.x
<15>Nov 14 14:41:15 loader: intf: numDns: 2
...


> 2) When starting anaconda you get an "exec: Permission Denied" error. Then
> the machine shuts down and reboots. HTTP install works fine without
> changing any permissions.

we've seen this bug internally, and also reported by beta testers with beta
candidates ... this usually occurs when anaconda is loading it's second stage
install image ... generally the errors have been one of two things:

1) bad permissions on the install .img files in the source tree
2) bad/corrupt/flaky install .img contents

We've not noticed this with production trees in test (ie official 6.2 & 7
versions) ...

do either of these scenarios apply in your situation ...? are you using the
final versions of 6.2 or 7 (not betas) ...?
Comment 9 ckloiber 2000-11-14 11:50:21 EST
Unfortunately this occured many months ago, and the network at work has changed.
There is no longer a DHCP server on my subnet due to internal politics between
IS and the Help Desk (basically IS won't allow services that are not firmly
under it's control- even on an isolated subnet whose primary purpose was to
allow experimentation). At the time it happened with rawhide, pinstripe, and
with the 7.0 gold (not respin) copy. I have not tried an nfs install since then
with the respins. I can tell you that my Alpha is running 6.2 with all updates
and a custom 2.2.18-3 kernel (Red Hat not providing proper support for my IDE
chipsets) using Andre Hedrick's IDE patches.

Data was moved into the nfs/ftp/http share using 'cp -avR' so the permissions
should be as correct as they were on the cd.
Comment 10 Michael Fulbright 2000-11-22 12:35:01 EST
Thank you for the report. If you have similar problems again please reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.