Bug 171969 - -devel subpkg
Summary: -devel subpkg
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcl   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gérard Milmeister
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-28 14:44 UTC by Rex Dieter
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-28 18:27:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rex Dieter 2005-10-28 14:44:44 UTC
rpmlint suggests following files could/should be packaged in a -devel subpkg:

%files devel
%defattr(-,root,root,-)
%{_libdir}/gcl-%{version}/h/
%{_libdir}/gcl-%{version}/unixport/lib*.a

Assuming, of course, you don't think this is a hairbrained idea... (-:

BTW, any reason gcl hasn't been built on/for development/fc5 yet?

Comment 1 Gérard Milmeister 2005-10-28 18:21:26 UTC
(In reply to comment #0)
> rpmlint suggests following files could/should be packaged in a -devel subpkg:
> 
> %files devel
> %defattr(-,root,root,-)
> %{_libdir}/gcl-%{version}/h/
> %{_libdir}/gcl-%{version}/unixport/lib*.a
> 
> Assuming, of course, you don't think this is a hairbrained idea... (-:
We could do this, I would prefer not to, unless we know exactly what
should go into the devel package. I consider gcl a development package
itself, so the problem isn't one :-)

> BTW, any reason gcl hasn't been built on/for development/fc5 yet?
Just tried again to build on fc5:
http://buildsys.fedoraproject.org/logs/fedora-development-extras/319-gcl-2.6.7-4.fc5/i386/build.log

If you come up with a patch, please go ahead!
BTW, I implemented the same personality hack as in sbcl.

In any case, we should communicate with upstream to make gcl compiler better.
I don't think it is a high priority though, as we have already clisp and sbcl.

Comment 2 Rex Dieter 2005-10-28 18:27:57 UTC
>  I consider gcl a development package itself

Good point, nevermind.

> In any case, we should communicate with upstream to make gcl compiler better.

Yeah, at least let them know compiling fails with gcc-4.0.2 (assuming it's a gcc
and not a glibc thing).


Note You need to log in before you can comment on or make changes to this bug.