Bug 171979 - Kernel menuconfig fails to auto-select driver dependency
Kernel menuconfig fails to auto-select driver dependency
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-28 12:21 EDT by Steve Snyder
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-01 10:44:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Snyder 2005-10-28 12:21:44 EDT
From Bugzilla Helper:
User-Agent: Opera/8.5 (X11; Linux i686; U; en)

Description of problem:
When using menuconfig to reconfigure the kernel, opting to build CONFIG_VORTEX 
as static results in the inability to link the kernel.  This is because 
CONFIG_MII, a dependant of CONFIG_VORTEX, is not also selected for static build. 
 Manually opting for a static CONFIG_MII allows the kernel to link.


Version-Release number of selected component (if applicable):
kernel-2.6.9-22.0.1.EL

How reproducible:
Always

Steps to Reproduce:
1. On RHEL4-U2, unpack and prep the kernel source in the usual way:

  rpm -ivh /tmp/kernel-2.6.9-22.0.1.EL.src.rpm
  rpmbuild -bp --target i686 SPECS/kernel.spec

2. Use standard RHEL4 config as a base

3. Run "make menuconfig" and change "Vortex/Boomerang" device from (RHEL4 
default) module to static.

4. Build kernel from source.


Actual Results:    UPD     include/linux/compile.h
  CC      init/version.o
  LD      init/built-in.o
  LD      .tmp_vmlinux1
drivers/built-in.o(.text+0x72e40): In function `vortex_nway_reset':
drivers/net/3c59x.c:2921: undefined reference to `mii_nway_restart'
drivers/built-in.o(.text+0x72f6a): In function `vortex_get_link':
drivers/net/3c59x.c:2935: undefined reference to `mii_link_ok'
drivers/built-in.o(.text+0x73099): In function `vortex_get_settings':
drivers/net/3c59x.c:2949: undefined reference to `mii_ethtool_gset'
drivers/built-in.o(.text+0x731c9): In function `vortex_set_settings':
drivers/net/3c59x.c:2963: undefined reference to `mii_ethtool_sset'
drivers/built-in.o(.text+0x73530): In function `vortex_ioctl':
include/linux/mii.h:150: undefined reference to `generic_mii_ioctl'
make: *** [.tmp_vmlinux1] Error 1


Expected Results:  Kernel drivers which are selected for static build should also have their 
dependencies automatically selected for static build.


Additional info:
Comment 1 Jason Baron 2005-11-01 10:44:10 EST
hmm these are already both built as modules. We do not support re-compiled kernels.

Note You need to log in before you can comment on or make changes to this bug.