Bug 171992 - Red Hat Cluster documentation missing key information
Red Hat Cluster documentation missing key information
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rh-cs-en (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Kennedy
John Ha
: Documentation
Depends On:
Blocks: 190206
  Show dependency treegraph
 
Reported: 2005-10-28 16:24 EDT by Josef Bacik
Modified: 2014-08-04 18:15 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHEL 4.4 RHEL 4.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-05 15:20:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Bacik 2005-10-28 16:24:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050719 Red Hat/1.0.6-1.4.1 Firefox/1.0.6

Description of problem:
The cluster suite documentation is missing the following information (this relates to the GFS documentation as well)

- there is nothing detailing the fact that RHCS 4 no longer requires shared storage, or how to setup RHCS 4 without shared storage
- using CLVM
- using DM Multipathing with CLVM
- there is no where (that i can see) in the GFS documentation that indicates that you have to setup the cluster with system-config-cluster before doing the GFS part


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.No repoduction steps
2.
3.
  

Additional info:
Comment 3 Kiersten (Kerri) Anderson 2007-05-21 18:19:13 EDT
Moving this bug to the 4.6 release since 4.5 has already been released.
Comment 4 Michael Hideo 2007-06-06 00:42:26 EDT
Adding 'cc ecs-dev-list@redhat.com for tracking
Comment 5 Paul Kennedy 2007-08-30 17:54:44 EDT
Progress:

We have restructured the documentation set for Red Hat Cluster Suite and GFS.

The issues are being addressed as follows:

- there is nothing detailing the fact that RHCS 4 no longer requires shared
storage, or how to setup RHCS 4 without shared storage -- This is still an
outstanding issue and needs to be addressed along with how to set up shared disk
for use qdisk.

- using CLVM -- We have published a book on this:
http://www.redhat.com/docs/manuals/enterprise/RHEL-5-manual/Cluster_Logical_Volume_Manager/index.html

- using DM Multipathing with CLVM -- Draft underway for DM-Multipath:
https://engineering.redhat.com/docbot/en-US/Storage_And_Cluster/5.2.0/html/DM_Multipath/index.html

- there is no where (that i can see) in the GFS documentation that indicates
that you have to setup the cluster with system-config-cluster before doing the
GFS part -- It is noted as part of requirements in the GFS doc:
http://www.redhat.com/docs/manuals/csgfs/browse/4.5/SAC_Global_File_System/s1-sysreq-rhcs.html
Comment 6 Paul Kennedy 2007-09-05 15:20:45 EDT
Following up on Comment #5:

Regarding the first item:

The RHEL 4.4 doc addresses the change here:

http://www.redhat.com/docs/manuals/csgfs/browse/rh-cs-en/ch-overview.html#S1-RHCM-FEATURES

Later, the document does provide information about configuring the cluster in
this section:
http://www.redhat.com/docs/manuals/csgfs/browse/rh-cs-en/ch-software.html


Comment 7 Paul Kennedy 2007-09-05 16:15:39 EDT
Closing this bug as fixed in CURRENTRELEASE. Because work is underway for the
DM-Multipath issue and because scope for that effort is wider than the issue
addressed here, have opened separate bug: Bug 279271.

Note that link for CLVM doc for RHEL 4 is this instead of the one noted in
Comment #5:
http://www.redhat.com/docs/manuals/csgfs/browse/4.5/SAC_Cluster_Logical_Volume_Manager/index.html

Note You need to log in before you can comment on or make changes to this bug.