Bug 172003 - system doesn't suspend to memory
system doesn't suspend to memory
Status: CLOSED DUPLICATE of bug 171648
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-28 18:38 EDT by Anatoly V. Lebedev
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 16:22:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anatoly V. Lebedev 2005-10-28 18:38:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051025 Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
when i do echo "mem">/sys/power/state screen stand in console mode and say:
PM: Preparing system for mem sleep
Stopping tasks: ======================================================
============================
 stopping tasks failed (1 tasks remaining)
Restarting tasks...<6> Strange, kauditd not stopped
 done


It's works till kernel-2.6.13-1.1603_FC5 and stop works for every newly till kernel-2.6.14-1.1632_FC5

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1632_FC5

How reproducible:
Always

Steps to Reproduce:
1. open terminal as root
2. type echo 'mem' > /sys/power/state

  

Actual Results:  runing system

Expected Results:  system in suspend

Additional info:
Comment 1 Anatoly V. Lebedev 2005-10-28 18:40:07 EDT
00:00.0 Host bridge: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to
I/O Controller (rev 02)
00:00.1 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor
to I/O Controller (rev 02)
00:00.3 System peripheral: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor
to I/O Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82852/855GM Integrated
Graphics Device (rev 02)
00:02.1 Display controller: Intel Corporation 82852/855GM Integrated Graphics
Device (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI
Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge
(rev 03)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Controller (rev 03)
01:0a.0 CardBus bridge: O2 Micro, Inc. OZ6933/711E1 CardBus/SmartCardBus
Controller (rev 20)
01:0a.1 CardBus bridge: O2 Micro, Inc. OZ6933/711E1 CardBus/SmartCardBus
Controller (rev 20)
01:0c.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5705M_2 Gigabit
Ethernet (rev 03)
01:0d.0 Network controller: Intel Corporation PRO/Wireless 2200BG (rev 05)
01:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000
Controller (PHY/Link)
Comment 2 Vladimir Kondratiev 2005-10-30 04:13:57 EST
I see the same problem.
Vanilla 2.6.14 kernel from www.kernel.org
IBM T42p

Same system, when booted vanilla 2.6.13 (same .config) do suspend/resume OK.

I suggest to raise severity since it block usage on laptops.

Also, it is worth to report to kernel bugzilla. I tried, but bugzilla.kernel.org
seems to be down.
Comment 3 Vladimir Kondratiev 2005-11-02 10:33:03 EST
corresponded bug in kernel bugzilla #5524
http://bugzilla.kernel.org/show_bug.cgi?id=5524
Comment 4 Dave Jones 2005-11-04 16:22:58 EST

*** This bug has been marked as a duplicate of 171648 ***

Note You need to log in before you can comment on or make changes to this bug.