Bug 172008 - Upgrade to upstream Openswan to 2.4.2dr5
Upgrade to upstream Openswan to 2.4.2dr5
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openswan (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-28 21:29 EDT by Albert Strasheim
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-07 03:49:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Albert Strasheim 2005-10-28 21:29:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

Description of problem:
Hello

Openswan 2.4.2dr5 has been released which fixes various NAT traversal problems.

Also, there is a kernel patch against 2.6.11.2 which doesn't seem to be in 2.6.14 upstream or in the latest FC devel kernel. I'm not familiar with the details of this patch, but this looks like something that should be included with the FC kernel.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

  

Additional info:

http://lists.openswan.org/pipermail/users/2005-October/006996.html
http://www.openswan.org/code/
http://anoncvs.openswan.org/cgi-bin/viewcvs.cgi/openswan-2/
http://cvs.fedora.redhat.com/viewcvs/devel/kernel/
Comment 1 Albert Strasheim 2005-10-31 02:24:06 EST
AFAICT, the kernel patch is for NAT traversal when using KLIPS instead of 26sec,
so I don't think it needs to be applied.

Note You need to log in before you can comment on or make changes to this bug.