Bug 172012 - iscsid tasks don't terminate when connection to server fails
iscsid tasks don't terminate when connection to server fails
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Christie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-28 23:28 EDT by Kurtis D. Rader
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 14:51:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kurtis D. Rader 2005-10-28 23:28:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; Linux i686; U; en) Opera 8.5

Description of problem:
My customer copied the iscsi client config from one system to another and did 
not change the initiator IDs (or anything else). They then restarted the iscsi 
client service on the new system. That resulted in a new iscsid task being 
started at one minute intervals. Which wouldn't be a problem except that the old 
iscsid never terminates. Four days later there were 6000 iscsid tasks running.

Near the time of the appearance of the first extraneous iscsid task we see the 
following in the /var/log/messages file:

Sep 26 09:18:25 blade-4 kernel: iSCSI:
    target requests logout within 5 seconds for session to blade-3-3
Sep 26 09:18:25 blade-4 kernel: iSCSI:
    session f6040000 to blade-3-3 logged out at 61199927
Sep 26 09:18:25 blade-4 kernel: iSCSI:
    bus 0 target 20 trying to establish session f6040000 to portal
    0, address 10.10.10.9 port 3260 group 1
Sep 26 09:18:25 blade-4 kernel: iSCSI:
    session f6040000 login rejected: initiator failed authorization
    with target iqn.1986-03.com.ibm.2520114.20050902124751.blade-3-3
Sep 26 09:18:25 blade-4 kernel: iSCSI:
    session f6040000 to blade-3-3 waiting 1 seconds
    before next login attempt
Sep 26 09:18:26 blade-4 kernel: iSCSI:
    bus 0 target 20 trying to establish session f6040000 to portal
    0, address 10.10.10.9 port 3260 group 1
Sep 26 09:18:26 blade-4 kernel: iSCSI:
    session f6040000 login rejected: initiator failed authorization
    with target iqn.1986-03.com.ibm.2520114.20050902124751.blade-3-3
Sep 26 09:18:26 blade-4 kernel: iSCSI:
    session f6040000 to blade-3-3 waiting 1 seconds
    before next login attempt
Sep 26 09:18:27 blade-4 kernel: iSCSI:
    bus 0 target 20 trying to establish session f6040000 to portal
     1, address 10.10.10.10 port 3260 group 1
Sep 26 09:18:28 blade-4 kernel: iSCSI:
    session f6040000 to blade-3-3 failed to connect, rc -111,
    Connection refused
Sep 26 09:18:28 blade-4 kernel: iSCSI:
    session f6040000 connect failed at 61200166
Sep 26 09:18:28 blade-4 kernel: iSCSI:
    session f6040000 iSCSI: session f6040000 retrying all the portals
    again, since the portal list got exhausted
Sep 26 09:18:28 blade-4 kernel: iSCSI:
    session f6040000 to blade-3-3 waiting 1 seconds before
    next login attempt
Sep 26 09:18:29 blade-4 kernel: iSCSI:
    bus 0 target 20 trying to establish session f6040000 to portal
    0, address 10.10.10.9 port 3260 group 1
Sep 26 09:18:29 blade-4 kernel: iSCSI:
    session f6040000 login rejected: initiator failed authorization
    with target iqn.1986-03.com.ibm.2520114.20050902124751.blade-3-3
Sep 26 09:18:29 blade-4 kernel: iSCSI:
    session f6040000 to blade-3-3 waiting 1 seconds before
    next login attempt

This is followed by the following sequence of messages which repeats at one 
minute intervals:

Sep 25 04:02:06 blade-5 iscsid[2368]: 
    Connected to Discovery Address 10.10.10.9 
Sep 25 04:03:06 blade-5 iscsid[2368]: 
    Connection to Discovery Address 10.10.10.9 closed 
Sep 25 04:03:06 blade-5 iscsid[2368]: 
    Connected to Discovery Address 10.10.10.9 
Sep 25 04:04:06 blade-5 iscsid[2368]: 
    Connection to Discovery Address 10.10.10.9 closed 
Sep 25 04:04:06 blade-5 iscsid[2368]: 
    Connected to Discovery Address 10.10.10.9 
Sep 25 04:05:06 blade-5 iscsid[2368]: 
    Connection to Discovery Address 10.10.10.9 closed 


Version-Release number of selected component (if applicable):
iscsi-initiator-utils-3.6.2-7

How reproducible:
Didn't try

Steps to Reproduce:

  

Additional info:
Comment 1 Mike Christie 2005-10-29 18:30:14 EDT
So you have two initiators with the same initaitor name connecting to the same
target? This is just not a valid config option. You could try putting

Continuous=no

in the iscsi.conf file, but this is just not a valid setup for iscsi.
Comment 2 Kurtis D. Rader 2005-10-29 22:04:43 EDT
Both I and the joint customer I'm supporting understand that what they did is 
not legal and will cause problems. No one is disputing that a mistake of this 
nature should cause session establishment problems. But nonetheless the iscsid 
task shouldn't spawn a new copy of itself at one minute intervals that never 
terminate. If it can't connect it should exit. Or, if it makes more sense that 
it remain running in order to continue attempting to establish a session then 
the top level daemon shouldn't spawn new instances for the same target.
Comment 3 RHEL Product and Program Management 2007-10-19 14:51:54 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.