Bug 172015 - no longer reports filename of crashed app when run on core files.
no longer reports filename of crashed app when run on core files.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: file (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
Fedora Extras Quality Assurance
: Reopened
: 235267 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-29 01:57 EDT by Dave Jones
Modified: 2015-01-04 17:22 EST (History)
4 users (show)

See Also:
Fixed In Version: 4.16-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 17:04:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2005-10-29 01:57:55 EDT
FC4 would print info like..

core.2461: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV), SVR4-style,
from 'gdmgreeter'

current rawhide..

core.2107: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV), SVR4-style
Comment 1 Radek Vokal 2005-10-31 02:47:36 EST
Fixed
Comment 2 Dave Jones 2007-08-14 00:11:24 EDT
this is still broken.

core.17152: ELF 32-bit LSB core file Intel 80386, version 1 (SYSV), SVR4-style

file 4.21-2.fc8
Comment 3 Martin Bacovsky 2007-08-20 10:02:44 EDT
*** Bug 235267 has been marked as a duplicate of this bug. ***
Comment 4 Martin Bacovsky 2007-08-20 10:05:29 EDT
It seems that ELF header in core files was changed and file was unable to find
correct notes section. This issue should be fixed in RAWHIDE (file-4.21-3.fc8)
Comment 5 Bryn M. Reeves 2007-08-22 16:58:29 EDT
Still broken for me:

[breeves@thunderbird6 ~]$ rpm -q file file-libs
file-4.21-2.fc8
file-libs-4.21-2.fc8
[breeves@thunderbird6 ~]$ file core.*
core.10030: ELF 64-bit LSB core file x86-64, version 1 (SYSV), SVR4-style
core.10642: ELF 64-bit LSB core file x86-64, version 1 (SYSV), SVR4-style
core.10797: ELF 64-bit LSB core file x86-64, version 1 (SYSV), SVR4-style
core.21698: ELF 64-bit LSB core file x86-64, version 1 (SYSV), SVR4-style
core.25245: ELF 64-bit LSB core file x86-64, version 1 (SYSV), SVR4-style
Comment 6 Bryn M. Reeves 2007-08-22 17:04:04 EDT
Ignore me - it's working fine with 4.21-3. Not enough coffee.

[breeves@thunderbird6 ~]$ file core.* 
core.10030: ELF 64-bit LSB core file x86-64, version 1 (SYSV), SVR4-style, from
'nm-applet'
core.10642: ELF 64-bit LSB core file x86-64, version 1 (SYSV), SVR4-style, from
'thunderbird-bin'

Note You need to log in before you can comment on or make changes to this bug.