Bug 172019 - Trying to suspend or hibernate on FC5 results in a kernel crash on Inspiron 6000
Trying to suspend or hibernate on FC5 results in a kernel crash on Inspiron 6000
Status: CLOSED DUPLICATE of bug 171648
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-29 07:36 EDT by Reshat Sabiq
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 16:23:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reshat Sabiq 2005-10-29 07:36:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b5) Gecko/20051008 Fedora/1.5-0.5.0.beta2 Firefox/1.4.1

Description of problem:
Note this line below:
kernel: Restarting tasks...<6> Strange, kauditd not stopped

I assume it's a kernel problem, but perhaps it's an auditd problem.

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1623_FC5

How reproducible:
Always

Steps to Reproduce:
1. Choose Suspend or Hibernate from GNOME Power Manager
2. Kernel crashes
3. Look into /var/log/messages after forcing a reboot.
  

Actual Results:  Kernel crashed and the computer never shutdown.

Expected Results:  Suspend or Hibernate, so that a resume could be attempted later.

Additional info:


Oct 24 06:40:24 dizustu2 kernel: audit(:0): major=252 name_count=0: freeing multiple contexts (1)
Oct 24 06:40:24 dizustu2 kernel: audit(:0): major=113 name_count=0: freeing multiple contexts (2)
Oct 24 06:40:32 dizustu2 kernel: Stopping tasks: ================================================================================================================
Oct 24 06:40:32 dizustu2 kernel:  stopping tasks failed (1 tasks remaining)
Oct 24 06:40:32 dizustu2 kernel: Restarting tasks...<6> Strange, kauditd not stopped
Oct 24 06:40:32 dizustu2 kernel:  done
Oct 24 06:40:34 dizustu2 kernel: audit(:0): major=252 name_count=0: freeing multiple contexts (1)
Oct 24 06:40:34 dizustu2 kernel: audit(:0): major=113 name_count=0: freeing multiple contexts (2)
Oct 24 06:43:00 dizustu2 shutdown: shutting down for system halt
Oct 24 06:43:01 dizustu2 init: Switching to runlevel: 0


[root@dizustu2 sbin]# rpm -qif auditd
Name        : audit                        Relocations: (not relocatable)
Version     : 1.0.7                             Vendor: Red Hat, Inc.
Release     : 1                             Build Date: Wed 19 Oct 2005 03:16:05 PM CDT
Install Date: Sun 23 Oct 2005 07:14:35 AM CDT      Build Host: tweety.build.redhat.com
Group       : System Environment/Daemons    Source RPM: audit-1.0.7-1.src.rpm
Size        : 371010                           License: GPL
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://people.redhat.com/sgrubb/audit/
Summary     : User space tools for 2.6 kernel auditing.
Description :
The audit package contains the user space utilities for
storing and searching the audit records generate by
the audit subsystem in the Linux 2.6 kernel.
Comment 1 Reshat Sabiq 2005-10-29 07:46:48 EDT
Here's the rest of the log, where i had to eventually power it off:

Oct 24 06:43:01 dizustu2 gconfd (rsa-2878): Received signal 15, shutting down
cleanly
Oct 24 06:43:02 dizustu2 gconfd (rsa-2878): Exiting
Oct 24 06:43:02 dizustu2 su(pam_unix)[3122]: session closed for user root
Oct 24 06:43:02 dizustu2 gdm(pam_unix)[2761]: session closed for user rsa
Oct 24 06:43:03 dizustu2 dbus: Can't send to audit system: USER_AVC pid=2447
uid=81 loginuid=-1 message=avc:  5 AV entries and 5/512 buckets used, longest
chain length 1
Oct 24 06:43:03 dizustu2 xfs[2413]: terminating
Oct 24 06:43:04 dizustu2 xinetd[2333]: Exiting...
Oct 24 06:43:06 dizustu2 rpc.statd[1917]: Caught signal 15, un-registering and
exiting.
Oct 24 06:43:06 dizustu2 auditd[1932]: The audit daemon is exiting.
Oct 24 06:43:06 dizustu2 kernel: audit(1130154186.489:189): audit_pid=0 old=1932
by auid=4294967295
Oct 24 06:43:06 dizustu2 kernel: audit(1130154186.617:190): SELinux: 
unrecognized netlink message type=1009 for sclass=49
Oct 24 06:43:06 dizustu2 kernel:
Oct 24 06:43:06 dizustu2 kernel: audit(1130154186.617:190): arch=40000003
syscall=102 success=yes exit=16 a0=b a1=bfb15580 a2=8052628 a3=bfb15630 items=0
pid=3833 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0
comm="auditctl" exe="/sbin/auditctl"
Oct 24 06:43:06 dizustu2 kernel: audit(1130154186.617:190):
saddr=100000000000000000000000
Oct 24 06:43:06 dizustu2 kernel: audit(1130154186.617:190): nargs=6 a0=3
a1=bfb1989c a2=10 a3=0 a4=bfb15630 a5=c
Oct 24 06:43:06 dizustu2 kernel: audit(1130154186.717:191): SELinux: 
unrecognized netlink message type=1009 for sclass=49
Oct 24 06:43:06 dizustu2 kernel:
Oct 24 06:43:06 dizustu2 kernel: audit(1130154186.717:191): arch=40000003
syscall=102 success=yes exit=16 a0=b a1=bfb15570 a2=8052628 a3=bfb15620 items=0
pid=3833 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0
comm="auditctl" exe="/sbin/auditctl"
Oct 24 06:43:06 dizustu2 kernel: audit(1130154186.717:191):
saddr=100000000000000000000000
Oct 24 06:43:06 dizustu2 kernel: audit(1130154186.717:191): nargs=6 a0=3
a1=bfb1988c a2=10 a3=0 a4=bfb15620 a5=c
Oct 24 06:43:06 dizustu2 kernel: Kernel logging (proc) stopped.
Oct 24 06:43:06 dizustu2 kernel: Kernel log daemon terminating.
Oct 24 06:43:08 dizustu2 exiting on signal 15
Comment 2 Reshat Sabiq 2005-10-29 07:50:17 EDT
Above, i believe the crash has occurred between 6:40:34 and 6:43.
Comment 3 Andrew Duggan 2005-10-31 17:14:25 EST
Same symptom for this kernel except for the "crash" on a Gateway 450.  System
just immediately "resumed".
Comment 4 Reshat Sabiq 2005-10-31 23:07:40 EST
I believe 172039 was caused by this bug, and wouldn't have happened otherwise.
I'll avoid using Suspend and Hibernate for now, except maybe on a testing partition.
Comment 5 Dave Jones 2005-11-04 16:23:25 EST

*** This bug has been marked as a duplicate of 171648 ***

Note You need to log in before you can comment on or make changes to this bug.