Bug 172029 - Disabling ACPI in kernel build causes link failure
Summary: Disabling ACPI in kernel build causes link failure
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-29 14:28 UTC by Steve Snyder
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-01 15:25:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Snyder 2005-10-29 14:28:35 UTC
From Bugzilla Helper:
User-Agent: Opera/8.5 (X11; Linux i686; U; en)

Description of problem:
Starting with the standard configuration (file /boot/config-2.6.9-22.0.1.EL, 
from the i686 kernel RPM) I deselected ACPI support in "make menuconfig".  When 
building the kernel I received the link error shown below.

Version-Release number of selected component (if applicable):
kernel-2.6.9-22.0.1.EL

How reproducible:
Didn't try

Steps to Reproduce:
1.  Unpack and prep the standard source in the usual way:

  rpm -i /tmp/kernel-2.6.9-22.0.1.EL.src.rpm
  rpmbuild -bp --target i686 SPECS/kernel.spec

2. Run "make menuconfig" against standard kernel config file, deselect ACPI

3. Build kernel
  

Actual Results:    LD      init/built-in.o
  LD      .tmp_vmlinux1
arch/i386/kernel/built-in.o(.init.text+0x1518): In function `setup_arch':
: undefined reference to `acpi_boot_table_init'
make: *** [.tmp_vmlinux1] Error 1


Expected Results:  The kernel build should not reference device support that I have disabled.


Additional info:

Comment 1 Jason Baron 2005-11-01 15:25:09 UTC
hi,

We don't support rhel4 kernels re-compiled with alternative configurations.

thanks.

Comment 2 Jason Baron 2005-11-01 15:26:36 UTC
perhaps acpi=off on the kernel command line will get you what you want?

Comment 3 Steve Snyder 2005-11-01 18:21:33 UTC
Well, I'm not terribly upset by the inability to deselect ACPI.  I can't use 
ACPI, so I thought I'd save a little memory by removing the ACPI support 
altogether.  Doing acpi=off does indeed quiet the boot-time complaints.

I just filed this report because I thought you would be interested that the ACPI 
option is no longer optional.



Note You need to log in before you can comment on or make changes to this bug.