Bug 172040 - Running "top" or "ps" as user causes lots of "avc: denied"
Running "top" or "ps" as user causes lots of "avc: denied"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-29 15:02 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.27.2-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-03 18:57:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-10-29 15:02:16 EDT
Description of problem:
[...]
Oct 29 20:59:21 tux kernel: audit(1130612361.474:303): avc:  denied  { read } 
for  pid=5828 comm="ps" name="stat" dev=proc ino=164364302 scontext=user_u:
system_r:unconfined_t:s0 tcontext=system_u:system_r:unconfined_t:s0-s0:c0.c255 
tclass=file
Oct 29 20:59:21 tux kernel: audit(1130612361.474:304): avc:  denied  { read } 
for  pid=5828 comm="ps" name="stat" dev=proc ino=166985742 scontext=user_u:
system_r:unconfined_t:s0 tcontext=user_u:system_r:sysadm_su_t:s0-s0:c0.c255 
tclass=file
Oct 29 20:59:21 tux kernel: audit(1130612361.474:305): avc:  denied  { read } 
for  pid=5828 comm="ps" name="stat" dev=proc ino=167051278 scontext=user_u:
system_r:unconfined_t:s0 tcontext=root:system_r:unconfined_t:s0-s0:c0.c255 
tclass=file
[...]
Oct 29 20:59:46 tux kernel: audit(1130612386.647:320): avc:  denied  { read } 
for  pid=5829 comm="top" name="stat" dev=proc ino=29032462 scontext=user_u:
system_r:unconfined_t:s0 tcontext=system_u:system_r:udev_t:s0-s0:c0.c255 
tclass=file
Oct 29 20:59:46 tux kernel: audit(1130612386.651:321): avc:  denied  { read } 
for  pid=5829 comm="top" name="stat" dev=proc ino=112590862 scontext=user_u:
system_r:unconfined_t:s0 tcontext=system_u:system_r:unconfined_t:s0-s0:c0.c255 
tclass=file
Oct 29 20:59:46 tux kernel: audit(1130612386.651:322): avc:  denied  { read } 
for  pid=5829 comm="top" name="stat" dev=proc ino=163184654 scontext=user_u:
system_r:unconfined_t:s0 tcontext=system_u:system_r:unconfined_t:s0-s0:c0.c255 
tclass=file
[...]

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.27.2-10

How reproducible:
Run "top" or "ps" as non-root user.

Actual results:
Lots of "avc: denied" messages in syslog.

Expected results:
No "avc: denied" message in syslog.

Additional info:
SELinux targeted enforced.
Comment 1 Robert Scheck 2005-10-29 15:11:04 EDT
Seems to becaused by udevd, for example:

system_u:system_r:udev_t:s0-s0:c0.c255 root 443 0.0  0.0   1940   480 ?        
S<s  18:38   0:00 udevd -d
Comment 2 Daniel Walsh 2005-11-03 14:34:50 EST
Fixed in selinux-policy-targeted-1.27.2-12
Comment 3 Robert Scheck 2005-11-03 18:57:23 EST
Works, thank you!

Note You need to log in before you can comment on or make changes to this bug.