Bug 17205 - FP comparison optimization bug on i686.
FP comparison optimization bug on i686.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
http://gcc.gnu.org/ml/gcc-patches/200...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-03 12:09 EDT by Red Hat Bugzilla
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-07 18:02:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-09-03 12:09:22 EDT
When you use -O -march=i686 on gcc.c-torture/execute/ieee/920810-1.c,
the testcase will fail. I believe it is a regression, at least for me. 
It may have something to do FP comparison optimization on i686. I 
will take a look when I find time.
Comment 1 Red Hat Bugzilla 2000-09-03 15:42:59 EDT
Seems to happen both in our gcc and vanilla CVS head, looks like
combiner "optimizes" it out. Will try to debug it.
Comment 2 Red Hat Bugzilla 2000-09-07 18:02:28 EDT
Fixed by

http://gcc.gnu.org/ml/gcc-patches/2000-09/msg00092.html
Comment 3 Red Hat Bugzilla 2000-10-24 04:20:00 EDT
Should be fixed in gcc-2.96-60 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.