Bug 172074 - Kernel oops when using aterm/bash to run mc
Kernel oops when using aterm/bash to run mc
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-30 12:09 EST by Nathaniel Gephart
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-30 15:35:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathaniel Gephart 2005-10-30 12:09:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I have installed aterm using yum and I use it instead of xterm.  When I try to run aterm with its pseudo-transparency option and run mc.  I get a kernel oops and must restart the computer.  I have done 'strace aterm' and then run mc and mc will run, but it is very distorted.

Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1532_FC4

How reproducible:
Always

Steps to Reproduce:
1. run 'aterm -tr +sb'
2. run mc

Actual Results:  Kernel oops and the computer froze.

Expected Results:  MC should have run normally.

Additional info:

Oct 27 14:01:43 felix kernel: Oops: 0000 [#1]
Oct 27 14:01:43 felix kernel: Modules linked in: fglrx(U) parport_pc lp parport autofs4 video button battery usblp ac
 ohci_hcd ehci_hcd i2c_nforce2 i2c_core shpchp snd_intel8x0 snd_ac97_codec snd_seq_dummy snd_seq_oss snd_seq_midi_eve
nt snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc forcedeth 3c59x mi
i floppy dm_snapshot dm_zero dm_mirror ext3 jbd dm_mod sata_nv libata sbp2 ohci1394 ieee1394 sd_mod scsi_mod
Oct 27 14:01:43 felix kernel: CPU:    0
Oct 27 14:01:43 felix kernel: EIP:    0060:[<f8d3739e>]    Tainted: P      VLI
Oct 27 14:01:43 felix kernel: EFLAGS: 00010096   (2.6.13-1.1532_FC4) 
Oct 27 14:01:43 felix kernel: EIP is at sig_notifier+0xe/0x60 [fglrx]
Oct 27 14:01:43 felix kernel: eax: f8d63788   ebx: 00000012   ecx: f8d37390   edx: c1ab0000
Oct 27 14:01:43 felix kernel: esi: c6f54000   edi: c6f54f0c   ebp: 00000012   esp: c6f54e28
Oct 27 14:01:43 felix kernel: ds: 007b   es: 007b   ss: 0068
Oct 27 14:01:43 felix kernel: Process bash (pid: 10274, threadinfo=c6f54000 task=c1ab0000)
Oct 27 14:01:43 felix kernel: Stack: badc0ded c19966cc c6f54000 c013a3a5 00000012 00000013 d6535ec0 c1ab0474 
Oct 27 14:01:43 felix kernel:        c1ab0000 c6f54f0c 00000000 c013a6cf c023ad04 00000010 00000000 00000227 
Oct 27 14:01:43 felix kernel:        00000227 00000002 c6f54e84 c01204c0 c6f54000 c1ab0474 00002822 c6f54000 
Oct 27 14:01:43 felix kernel: Call Trace:
Oct 27 14:01:43 felix kernel:  [<c013a3a5>] __dequeue_signal+0x102/0x1b5
Oct 27 14:01:43 felix kernel:  [<c013a6cf>] dequeue_signal+0x277/0x382
Oct 27 14:01:43 felix kernel:  [<c023ad04>] avc_has_perm_noaudit+0x26/0xd1
Oct 27 14:01:43 felix kernel:  [<c01204c0>] activate_task+0x59/0x68
Oct 27 14:01:43 felix kernel:  [<c013f0b3>] get_signal_to_deliver+0x567/0x1057
Oct 27 14:01:43 felix kernel:  [<c0104274>] do_signal+0x4b/0x105
Oct 27 14:01:43 felix kernel:  [<c01652d8>] audit_syscall_exit+0x639/0x65b
Oct 27 14:01:43 felix kernel:  [<c0164c71>] audit_syscall_entry+0x130/0x15e
Oct 27 14:01:43 felix kernel:  [<c01a0334>] filp_close+0x3e/0x62
Oct 27 14:01:43 felix kernel:  [<c0109b75>] do_syscall_trace+0x112/0x123
Oct 27 14:01:43 felix kernel:  [<c0104355>] do_notify_resume+0x27/0x36
Oct 27 14:01:43 felix kernel:  [<c01044f6>] work_notifysig+0x13/0x15
Oct 27 14:01:43 felix kernel: Code: 04 24 03 00 00 00 e8 1c a0 ff ff 89 c2 f7 da eb e8 8d b6 00 00 00 00 8d bf 00 00 
00 00 83 ec 08 89 1c 24 8b 5c 24 0c 89 74 24 04 <8b> 53 04 8b 0a 85 c9 78 10 b8 01 00 00 00 8b 1c 24 8b 74 24 04 
Oct 27 14:01:43 felix kernel:  <0>Fatal exception: panic in 5 seconds
Comment 1 Dan Carpenter 2005-10-30 12:40:07 EST
It's probably something with the fglrx driver.

> Oct 27 14:01:43 felix kernel: EIP is at sig_notifier+0xe/0x60 [fglrx]

You should contact ATI about that because it's not open source.

Comment 2 Nathaniel Gephart 2005-10-30 13:27:38 EST
I updated the fglrx driver to the most recent version, now the kernel doesn't
oops, but mc is still very distorted in aterm.

Note You need to log in before you can comment on or make changes to this bug.