Bug 172075 - RFE: own /lib/modules/<version>/{extra,updates}
RFE: own /lib/modules/<version>/{extra,updates}
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: FutureFeature, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-30 13:09 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 16:23:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Create/own /lib/modules/<version>/{extra,updates} (2.15 KB, patch)
2005-10-30 13:09 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2005-10-30 13:09:29 EST
It would be nice to have the kernel package(s) create and own the "extra" and 
"updates" directories below /lib/modules/<version>. 
 
"extra" is the implied upstream suggestion from 
Documentation/kbuild/modules.txt and is intended to be a location for 
additional 3rd party modules not shipped with the kernel. 
 
"updates" is a directory for overriding shipped modules, module-init-tools 
looks from there first before descending to other directories. 
 
Including these dirs in the kernel package would be a good thing 
"documentation" wise, and external module packages following the above "rules" 
would not have to worry about their ownership. 
 
Untested patch against Rawhide attached; earlier distro versions would benefit 
from this too.
Comment 1 Ville Skyttä 2005-10-30 13:09:29 EST
Created attachment 120552 [details]
Create/own /lib/modules/<version>/{extra,updates}

Note You need to log in before you can comment on or make changes to this bug.