Bug 172093 - 2 sec Delay before querying root servers
2 sec Delay before querying root servers
Status: CLOSED DUPLICATE of bug 167188
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bind (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Ben Levenson
http://marc.theaimsgroup.com/?l=bind-...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-31 06:07 EST by Rainer Traut
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: bind-9.2.4-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-31 11:16:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rainer Traut 2005-10-31 06:07:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

Description of problem:
There is a 2sec delay between querying the nameserver and its query of the root server if it's not in dns cache.
It seems to be the same problem as described here:
http://marc.theaimsgroup.com/?l=bind-users&m=112929882425254&w=2

Version-Release number of selected component (if applicable):
bind-9.2.4-2

How reproducible:
Always

Steps to Reproduce:
1. do in console: host dell.com
2. wait minimum of 2 seconds
3. get the answer
  

Actual Results:  I used tethereal to debug:
the question reaches the dns server,
it waits exactly 2 seconds, then queries the root servers/authoritative servers of the requested domain

Expected Results:  Immediate response

Additional info:

It seems to be a problem with ipv6, bind is compiled with ipv6 support but does not notice it runs without it?
Comment 1 Ralph Angenendt 2005-10-31 06:13:49 EST
Actually it seems to be this problem
<http://v6fix.net/db/bind9-ipv6-transport.html> which is fixed in 9.2.5 or
9.3.1. Maybe the fix can be backported from 9.2.5?
Comment 2 Jason Vas Dias 2005-10-31 11:16:14 EST
Yes, the fix for this problem has been backported into the next version of BIND
for RHEL-4: bind-9.2.4-12_EL4, which should be in a RHEL update release soon,
but which meanwhile can be downloaded from :
   http://people.redhat.com/~jvdias/bind/RHEL-4/
Comment 3 Jason Vas Dias 2005-10-31 11:18:10 EST

*** This bug has been marked as a duplicate of 167188 ***
Comment 4 Jordan Russell 2006-04-29 14:59:48 EDT
I'm also having this problem.
I tried to get the updated version you mentioned, but the directories under
http://people.redhat.com/~jvdias/bind/RHEL-4/9.2.4-12_EL4/ are all empty.

Is http://people.redhat.com/~jvdias/bind/RHEL-4/9.3.2-2_EL4/ safe for production
use? (Will Update 4 include this version?)
Comment 5 Jason Vas Dias 2006-04-29 16:05:31 EDT
In reply to comment #4, From Jordan Russell (jr-redhatbugs@quo.to),  on
2006-04-29 14:59 EST:
> I'm also having this problem.
> I tried to get the updated version you mentioned, but the directories under
> http://people.redhat.com/~jvdias/bind/RHEL-4/9.2.4-12_EL4/ are all empty.
> 
> Is http://people.redhat.com/~jvdias/bind/RHEL-4/9.3.2-2_EL4/ safe for production
> use? (Will Update 4 include this version?)

The bind version queued for delivery in RHEL-4-U4 is bind-9.2.4-16.EL4, 
which you can download from:
  http://people.redhat.com/~jvdias/bind/RHEL-4/9.2.4-16.EL4 
This version has this bug fixed, as well as fixes for all known BIND 9.2.4
bugs backported from 9.2.6, and the 'edns0-udp-size' feature backported
from 9.3.x .
There is also bind-9.3.2-2.EL4, available from: 
  http://people.redhat.com/~jvdias/bind/RHEL-4/9.3.2-2.EL4
bind-9.3.2-2.EL4 is not officially supported as a RHEL-4 update release,
as we are not allowed to upgrade packages by major version numbers in RHEL,
but is provided for customers requiring 9.3.2 features, and I as the bind
package maintainer do undertake to fully support it - it is built on our
production build servers for all RHEL-4 architectures and passes all known
bind tests.
Please try out one of the above versions and let me know of any issues -
I hope it resolves your problem .

Thanks & Regards,
Jason Vas Dias,
BIND package maintainer
Red Hat Inc.

Note You need to log in before you can comment on or make changes to this bug.