Bug 172143 - piecewise screensaver leaks memory at ~1MB/s
piecewise screensaver leaks memory at ~1MB/s
Status: CLOSED DUPLICATE of bug 170503
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: xscreensaver (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: 170417
  Show dependency treegraph
 
Reported: 2005-10-31 15:03 EST by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-02 15:21:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xscreensaver-4.18-stuff-piecewise-leak.patch (518 bytes, patch)
2005-10-31 15:03 EST, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2005-10-31 15:03:40 EST
+++ This bug was initially created as a clone of Bug #135164 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041002
Firefox/0.10.1

Description of problem:
I noticed that memory usage of my machine had grown considerably when
I came back after the screensaver was active. It seems that the
piecewise screensaver leaks memory at about 1MB/s


Version-Release number of selected component (if applicable):
xscreensaver-4.18-3

How reproducible:
Always

Steps to Reproduce:
1. run /usr/X11R6/lib/xscreensaver/piecewise
2. run top
3. Watch memory usage of piecewise process
    

Actual Results:  The piecewise process starts at about 5MB, but grows
in size each time the top window refreshes. After about 10 seconds the
memory usage is up to 15MB.

Additional info:

-- Additional comment from wtogami@redhat.com on 2004-10-15 04:37 EST --
It appears that the only place free() is done is within sweep(), but
it isn't freeing all newly allocated memory in each iteration.  I will
attempt to look into it again this weekend.

In the mean time I would suggest disabling this as a default
screensaver, or removing it entirely.  This is horribly inefficient
code even if it were working properly.

-- Additional comment from mattdm@mattdm.org on 2004-10-17 14:10 EST --
The same behavior is apparent in FC2's xscreensaver-4.14.

-- Additional comment from krh@redhat.com on 2004-10-19 13:05 EST --
Should be fixed in 4.18-4.
Comment 1 Bastien Nocera 2005-10-31 15:03:41 EST
Created attachment 120587 [details]
xscreensaver-4.18-stuff-piecewise-leak.patch
Comment 2 Ray Strode [halfline] 2005-11-02 15:21:42 EST

*** This bug has been marked as a duplicate of 170503 ***

Note You need to log in before you can comment on or make changes to this bug.