Bug 172161 - [RHEL4] Compilation problem: looking in /usr/lib instead of /usr/lib64
Summary: [RHEL4] Compilation problem: looking in /usr/lib instead of /usr/lib64
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: devhelp   
(Show other bugs)
Version: 4.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-01 01:11 UTC by Patrice Guay
Modified: 2008-02-29 13:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-29 13:10:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrice Guay 2005-11-01 01:11:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.12) Gecko/20050926 Red Hat/1.0.7-1.4.1.TL1 Firefox/1.0.7

Description of problem:
When compiling devhelp on the x86_64 architecture, compilation fails with this message:
/usr/lib/libpopt.so: could not read symbols: File in wrong format

This is simply due to the fact that the compiler is looking for libpopt.so in /usr/lib instead of /usr/lib64.


Version-Release number of selected component (if applicable):
devhelp-0.9.2-2.4.7

How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh http://updates.redhat.com/enterprise/4AS/en/os/SRPMS/devhelp-0.9.2-2.4.7.src.rpm
2. cd /usr/src/redhat/SPECS
3. rpmbuild -ba devhelp.spec


Actual Results:  Compilation aborts with the following message:
/usr/lib/libpopt.so: could not read symbols: File in wrong format

Expected Results:  Compilation should have completed without any error.

Additional info:

Comment 1 Patrice Guay 2005-11-01 01:18:49 UTC
The same error applies to these packages:
gnome-games-2.8.0-4
gnome-mag-0.11.7-1
gnome-nettool-0.99.3-2
gnome-terminal-2.7.3-2
gnome-utils-2.8.0-5
gok-0.11.8-1
hal-0.4.2-1.EL4
librsvg2-2.8.1-1


Comment 2 Martin Stransky 2008-02-29 13:10:48 UTC
I believe it's fixed now, right?


Note You need to log in before you can comment on or make changes to this bug.