Bug 172177 - clustat -x output is missing current/last owner
Summary: clustat -x output is missing current/last owner
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: rgmanager   
(Show other bugs)
Version: 4
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-01 04:00 UTC by Jiho Hahm
Modified: 2009-04-16 20:18 UTC (History)
2 users (show)

Fixed In Version: RHBA-2006-0173
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-06 20:22:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes behavior (836 bytes, patch)
2005-11-01 14:58 UTC, Lon Hohberger
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0173 normal SHIPPED_LIVE rgmanager bug fix update 2006-01-06 05:00:00 UTC

Description Jiho Hahm 2005-11-01 04:00:54 UTC
Description of problem:

clustat -x output always shows "(null)" or "none" for "owner" and "last_owner"
attributes.  The non-XML output of clustat reports the correct information. 
However, I need the XML output to integrate cluster status into my own
administration interface.  Because of the bug I have no way of knowing on which
cluster members the services are running.


Version-Release number of selected component (if applicable):

    rgmanager-1.9.39-0
    Problem did not happen in the previous release, 1.9.38-0.


How reproducible:


Steps to Reproduce:
1. Run "clustat"
2. Run "clustat -x"
3. Compare the results.
  
Actual results:

owner and last_owner attributes of <group> element is always "(null)" or "none"
while the non-XML clustat output shows the right data.

Expected results:


Additional info:

It looks like non-XML clustat output was improved to show which member is local
member and whether rgmanager is running.  This data should be returned in the
XML output as well.

The correct owner should be returned for "starting" status as well as "started",
so that a custom <script> resource can tell in which service's context it is
being invoked.

Comment 1 Lon Hohberger 2005-11-01 14:58:51 UTC
Created attachment 120603 [details]
Fixes behavior

Comment 2 Jiho Hahm 2005-11-01 18:33:19 UTC
The patch works.  Thanks for the quick response.

Comment 5 Red Hat Bugzilla 2006-01-06 20:22:52 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0173.html



Note You need to log in before you can comment on or make changes to this bug.