Bug 17224 - tcltk srpm does not build without already being installed
Summary: tcltk srpm does not build without already being installed
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: python   
(Show other bugs)
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-04 01:48 UTC by Jes Sorensen
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 23:53:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jes Sorensen 2000-09-04 01:48:53 UTC
Hi

The tcltk SRPM cannot compile the tkinter sub-package without tcltk already
being installed because it expects to find tk.h in the normal include path.

Jes

gcc -fPIC  -DWITH_APPINIT -I/usr/local/include -DWITH_TIX -g -O2
-I./../Include -I.. -DHAVE_CONFIG_H -c ./_tkinter.c
./_tkinter.c:79:16: tk.h: No such file or directory
./_tkinter.c:84:10:         #error "Tk 4.0 or 3.x are not supported -- use
4.1 or higher"
make[1]: *** [_tkinter.o] Error 1
make[1]: Leaving directory
`/disk1/jes/src/redhat/BUILD/Python-1.5.2/Modules'
make: *** [sharedmods] Error 2

Comment 1 Jeff Johnson 2000-10-06 21:34:48 UTC
This appears to be a python build problem , changing component.

Comment 2 Trond Eivind Glomsrxd 2002-08-13 23:53:42 UTC
Python is a separate package, and buildrequires tcltk.... no problem there.


Note You need to log in before you can comment on or make changes to this bug.