Bug 172251 - Cannot have tux default to listen on port other than 80
Cannot have tux default to listen on port other than 80
Status: CLOSED DUPLICATE of bug 70085
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tux (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ingo Molnar
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-01 17:32 EST by Sharif Nassar
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-01 17:38:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharif Nassar 2005-11-01 17:32:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
We'd like to be able to change the default listen port that tux listens on.

/etc/sysconfig/tux doesn't have any useful flags to set the listen port, and /proc/net/tux doesn't exist until the kernel module is loaded.

FEATURE REQUEST: Change /etc/init.d/tux to recognize a new  configuration feature in /etc/sysconfig/tux.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start tux. 
2. It listens on port 80 by default
3. Try to connect to 8990 .. Hey, it's not listening!
  

Actual Results:  
Connection refused.

Expected Results:  
Expected to talk to webserver on port 8990

Additional info:

My hack:
Add to /etc/init.d/tux (somewhere after module is loaded):
    if [ -n $LISTEN_URI ] ; then
        echo $LISTEN_URI > /proc/net/tux/0/listen/0
    fi

Add to /etc/sysconfig/tux:
LISTEN_URI=http://0.0.0.0:8990

Of course, this will only satisfy very simple configurations.
People who want to run multiple listeners may need a more evolved solution.
Comment 1 Sharif Nassar 2005-11-01 17:38:56 EST
Oh nuts.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=70085

3 years ago.


*** This bug has been marked as a duplicate of 70085 ***

Note You need to log in before you can comment on or make changes to this bug.