Bug 172285 - Yum should do sanity checks on repomd.xml
Yum should do sanity checks on repomd.xml
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-02 08:39 EST by Aaron VanDevender
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 01:39:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum.conf (253 bytes, text/plain)
2005-12-16 13:29 EST, Aaron VanDevender
no flags Details
fedora-devel.repo (233 bytes, text/plain)
2005-12-16 13:30 EST, Aaron VanDevender
no flags Details
fedora.repo (244 bytes, text/plain)
2005-12-16 13:30 EST, Aaron VanDevender
no flags Details
fedora-updates.repo (280 bytes, text/plain)
2005-12-16 13:31 EST, Aaron VanDevender
no flags Details
fedora-updates-testing.repo (282 bytes, text/plain)
2005-12-16 13:32 EST, Aaron VanDevender
no flags Details

  None (edit)
Description Aaron VanDevender 2005-11-02 08:39:46 EST
Recently, one or more yum repositories had present but empty repomd.xml files,
causing yum to bomb, giving an error that it could not load repomd.xml. Yum
should, upon downloading a repomd.xml, check to make sure the file is not empty
and a valid xml file with the correct schema. If not it should consider that
repository broken and move on to the next one.
Comment 1 Seth Vidal 2005-11-02 15:06:06 EST
could you please provide the error message you get?

thanks
Comment 2 Aaron VanDevender 2005-11-02 17:03:05 EST
Here is the error. This has been reported by a couple of people on the lists.
(I'm not losing my mind ;)

# yum update
Setting up Update Process
Setting up Repos
core                      100% |=========================| 1.1 kB    00:00
updates                   100% |=========================|    0 B    00:00
//var/cache/yum/updates/repomd.xml:1: parser error : Document is empty

^
//var/cache/yum/updates/repomd.xml:1: parser error : Start tag expected, '<'
not found

^
Cannot open/read repomd.xml file for repository: updates
Error importing repomd.xml from updates: Error: could not parse file
//var/cache/yum/updates/repomd.xml
Comment 3 Seth Vidal 2005-11-02 17:14:51 EST
are you using a mirrorlist or a single baseurl?
Comment 4 Aaron VanDevender 2005-11-03 02:47:08 EST
I'm using a mirror list with yum-2.4.0-0.fc4
Comment 5 Seth Vidal 2005-11-06 23:46:31 EST
You're using mirrorlists for that repository? If so then that means that all of
the mirrors are damaged the same way.

yum 2.4.0 is validating the repomd.xml, seeing it has no other place to get a
valid one from and exiting b/c the repository has failed out.

If you could, provide your yum.conf and all of your .repo files from
/etc/yum.repos.d

Comment 6 Aaron VanDevender 2005-12-16 13:29:03 EST
Created attachment 122334 [details]
yum.conf
Comment 7 Aaron VanDevender 2005-12-16 13:30:13 EST
Created attachment 122335 [details]
fedora-devel.repo
Comment 8 Aaron VanDevender 2005-12-16 13:30:55 EST
Created attachment 122336 [details]
fedora.repo
Comment 9 Aaron VanDevender 2005-12-16 13:31:31 EST
Created attachment 122337 [details]
fedora-updates.repo
Comment 10 Aaron VanDevender 2005-12-16 13:32:06 EST
Created attachment 122338 [details]
fedora-updates-testing.repo
Comment 11 Aaron VanDevender 2005-12-16 13:37:47 EST
So I've attached my yum.conf and all of the files in my yum.repos.d. They're not
terribly interesting however, they're just the stock files, but you asked so I'm
happy to oblige. Sorry it took so long.

I just realized that the files I've attached are from an FC3 machine, running
yum -2.2.2-0.fc3, which is the one that I have most recently seen the error (as
of last night), but I have seen this same thing happen on my FC4 machines as well.
Comment 12 Seth Vidal 2005-12-19 01:04:14 EST
You're sure this has happened on a 2.4.X release of yum?

on 2.2.X this could definitely happen buton 2.4.0 or 2.4.1 I doubt it.

try 2.4.1 from FC4 updates and let me know.

but don't give me two different reports in this bug - that's not helpful.
Comment 13 Aaron VanDevender 2005-12-19 01:39:37 EST
I know and I'm sorry about that. I had sort of forgotten about this bug for a
while, since I hadn't seen the symptom in a while. The other night I got the
error again, and so I was reminded about it and I uploaded the repo files from
the machine that most recently produced the error. After I uploaded the files I
realized that that particular machine is only FC3 and so I posted the comment
expalining the situation. But that's the way it goes when you have as many
machines and I do; it's hard to keep them all straight. But I'm 95% sure that I
have seen this bug on some of my FC4 machines, though none recently.

Perhaps it's best if you just forget about this for now. I'll close the bug, and
if I see it again on an FC4 machine, then I'll reopen it and post details.

Note You need to log in before you can comment on or make changes to this bug.