Bug 172310 - Pass service name to script resource invocation to let the script know which service is being controlled
Pass service name to script resource invocation to let the script know which...
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
: FutureFeature, Reopened
Depends On:
Blocks: 164915
  Show dependency treegraph
 
Reported: 2005-11-02 12:08 EST by Jiho Hahm
Modified: 2009-04-16 16:18 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2006-0173
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 09:53:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Make script.sh set service name in env of script being invoked (632 bytes, patch)
2005-11-02 12:08 EST, Jiho Hahm
no flags Details | Diff

  None (edit)
Description Jiho Hahm 2005-11-02 12:08:28 EST
Description of problem:

I have a custom <script> resource that needs to do some setup work specific to
the cluster <service> being started.  Update script.sh (patch attached) to pass
service name as environment variable.  The patch will let the script see service
name as OCF_RESKEY_service_name env var.

Version-Release number of selected component (if applicable):

    rgmanager-1.39.9-0
Comment 1 Jiho Hahm 2005-11-02 12:08:28 EST
Created attachment 120649 [details]
Make script.sh set service name in env of script being invoked
Comment 3 Lon Hohberger 2005-11-21 16:46:41 EST
Fixes in CVS - the inheritance uses the new-ish "%" delimiter so that we only
inherit the "name" attribute if it is, in fact, from a parent service resource.
Comment 5 Red Hat Bugzilla 2006-01-06 15:23:33 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0173.html
Comment 6 Jiho Hahm 2007-06-20 15:23:02 EDT
Hi, I'm reopening this bug because the service name is not passed when the
script resource is not a direct child element of <service>.  With the resource
dependency feature implemented in bug 212121, <script> resources can (and
usually will be) one or more levels removed from <service> because the
application being controlled by the script will depend on other resources like
IP address and filesystems.
Comment 7 Lon Hohberger 2007-06-21 09:48:48 EDT
Like in bug 231521 for rhel5?
Comment 8 Lon Hohberger 2007-06-21 09:53:33 EDT
I've created a different bug for this:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=245171

Comment 9 Jiho Hahm 2007-06-21 14:08:53 EDT
Yes, it's the same issue.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.