Bug 17233 - segmentation fault (tcsh)
Summary: segmentation fault (tcsh)
Status: CLOSED DUPLICATE of bug 17187
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 5.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-04 12:19 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-04 12:19:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-09-04 12:19:28 UTC
after updating the glibc to glibc-2.0.7-29.2 on a german redhat linux the
tcsh doesn't work anymore.  i tried it on 3 machines with redhat 5.2 linux
(i386). everytime the same error. 

$ tcsh
$ Segmentation fault (core dumped)

$ strace tcsh
	:
	:
open("/usr/share/locale/de_DE/LC_MESSAGES", O_RDONLY) = 3
fstat(3, {st_mode=0, st_size=0, ...})   = 0
close(3)                                = 0
open("/usr/share/locale/de_DE/LC_MESSAGES/SYS_LC_MESSAGES", O_RDONLY) = 3
fstat(3, {st_mode=0, st_size=0, ...})   = 0
mmap(0, 44, PROT_READ, MAP_PRIVATE, 3, 0) = 0x4000b000
close(3)                                = 0
open("/usr/share/locale/de_DE/LC_CTYPE", O_RDONLY) = 3
fstat(3, {st_mode=0, st_size=0, ...})   = 0
mmap(0, 10428, PROT_READ, MAP_PRIVATE, 3, 0) = 0x4000c000
close(3)                                = 0
brk(0x809b000)                          = 0x809b000
--- SIGSEGV (Speicherzugriffsfehler) ---
+++ killed by SIGSEGV +++

Comment 1 Jakub Jelinek 2000-09-04 12:22:14 UTC

*** This bug has been marked as a duplicate of 17187 ***


Note You need to log in before you can comment on or make changes to this bug.