Bug 172354 - agpgart: X tried to set rate=x0.
agpgart: X tried to set rate=x0.
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-03 04:14 EST by Dimitris
Modified: 2015-01-04 17:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 18:12:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dimitris 2005-11-03 04:14:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
After a few kernel updates, i found out that my 3D OpenGL performance was rather low, lower than before. I took a look at my 'dmesg' output and this is what i found:

agpgart: Found an AGP 3.5 compliant device at 0000:00:00.0.
agpgart: reserved bits set in mode 0x1f00021c. Fixed.
agpgart: X tried to set rate=x0. Setting to AGP3 x4 mode.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V3 device at 0000:01:00.0 into 4x mode


X tried to set rate to zero? hmm weird. Wait a minute, agp mode is set to 4x? Why not 8x? So thats why my 3D performance dropped, i'm running at half my AGP bandwidth.

Since i haven't made any changes to my hardware and my software changes have been updates to FC4 via 'yum', i'm guessing the problem could be with a recent kernel update (ok ok, i do run the closed-source nvidia drivers, but this problem appears to be related to agpgart/X only).

Hardware: Asus A7V600 motherboard, AthlonXP 2100+ cpu, NVIDIA GeForce FX 5600 video card.

# cat card
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       8x 4x
Registers:       0x1f000e1b:0x1f000311

# cat host-bridge
Host Bridge:     PCI device 1106:3189
Fast Writes:     Supported
SBA:             Supported
AGP Rates:       8x 4x
Registers:       0x1f000a1f:0x00000b11

# cat status
Status:          Enabled
Driver:          AGPGART
AGP Rate:        4x
Fast Writes:     Enabled
SBA:             Enabled

#dmesg | grep agpgart
agpgart: Detected VIA KT400/KT400A/KT600 chipset
agpgart: AGP aperture is 128M @ 0xf0000000
agpgart: Found an AGP 3.5 compliant device at 0000:00:00.0.
agpgart: reserved bits set in mode 0x1f00021c. Fixed.
agpgart: X tried to set rate=x0. Setting to AGP3 x4 mode.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 4x mode
agpgart: Putting AGP V3 device at 0000:01:00.0 into 4x mode


Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1532_FC4

How reproducible:
Always

Steps to Reproduce:
1. just boot into X



Actual Results:  AGP is set to 4x instead of 8x as before.

Expected Results:  AGP set to 8x.


Additional info:
Comment 1 Dave Jones 2005-11-04 18:12:11 EST
this is a bug in the nvidia driver.
it's trying to set the mode to something that doesn't exist in AGP3 mode.

After masking out the reserved bits, there's nothing left, so it's left with
"x0" mode, which makes no sense, so we auto-correct that to the safest AGP3 mode
(x4)

Note You need to log in before you can comment on or make changes to this bug.