Bug 172361 - rpm 4.4.3: undefined reference to `sepol_policy_file_create'
rpm 4.4.3: undefined reference to `sepol_policy_file_create'
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-03 07:43 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-12 13:09:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-11-03 07:43:22 EST
Description of problem:
Rebuilding of latest RPM ends with:

[...]
/usr/src/redhat/BUILD/rpm-4.4.3/lib/rpmchecksig.c:359: warning: the use of 
`mktemp' is dangerous, better use `mkstemp'
/usr/src/redhat/BUILD/rpm-4.4.3/rpmio/.libs/librpmio.a(rpmio.o): In function 
`mygethostbyname':
/usr/src/redhat/BUILD/rpm-4.4.3/rpmio/rpmio.c:765: warning: Using 
'gethostbyname' in statically linked applications requires at runtime the shared 
libraries from the glibc version used for linking
/usr/lib/libkrb5.a(hst_realm.o): In function `krb5int_get_fq_local_hostname':
: warning: Using 'gethostbyname_r' in statically linked applications requires at 
runtime the shared libraries from the glibc version used for linking
/usr/src/redhat/BUILD/rpm-4.4.3/rpmio/.libs/librpmio.a(url.o): In function 
`urlSplit':
/usr/src/redhat/BUILD/rpm-4.4.3/rpmio/url.c:513: warning: Using 'getservbyname' 
in statically linked applications requires at runtime the shared libraries from 
the glibc version used for linking
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_policy_kern_vers_max'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_policy_file_create'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_policydb_create'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_policy_file_set_mem'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_policydb_read'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_policydb_set_vers'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_policydb_to_image'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_policy_file_free'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_policydb_free'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_policy_file_free'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_policydb_free'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_policy_file_free'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_policydb_free'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_genusers'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_genbools_array'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_policy_kern_vers_min'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_policy_file_free'
/usr/lib/libselinux.a(load_policy.o): In function `selinux_mkload_policy':
: undefined reference to `sepol_genbools'
collect2: ld returned 1 exit status
make[2]: *** [rpmi] Error 1
make[2]: *** Waiting for unfinished jobs....

Version-Release number of selected component (if applicable):
rpm-4.4.3-0.33

How reproducible:
Everytime, try to rebuild rpm against latest Rawhide.

Actual results:
No rebuilding of rpm itself.

Expected results:
Rebuilding.

Additional info:
IIRC there were some bigger changes at headers and functions in SELinux a few 
weeks ago, but I'm not sure.
Comment 1 Jeff Johnson 2005-11-03 21:01:47 EST
Hmmm, rpm-4.4.3-0.33 builds for me on latest rawhide packages.

load_policy.o contains no symbols needed directly by rpmlib, nor
is there any routine that rpm uses from libselinux that references
a symbol in load_policy.o, so I'm a bit confused why -lsepol appears
to be needed.
Comment 2 Robert Scheck 2005-11-05 07:43:09 EST
Jeff, I think I know, what the problem was. I only took the .tar.gz into the 
last spec file from Rawhide and disabled the patches, that didn't apply. And
in Rawhide, there are some SELinux patches... ;-)

BTW, is there a possibility to include these into your upstream development? :)
Comment 3 Robert Scheck 2005-11-12 13:09:38 EST
Closing with CANTFIX, because it was my failure - sorry Jeff.

Note You need to log in before you can comment on or make changes to this bug.